Uploaded Files Don't Match Originals

I am trying to upload files to my server (hosted by GoDaddy) and am getting very strange results. The files are all ASCII but some have non-standard extensions.

If the files exist on the server (most do, but they are older) the files on the server RETAIN the original data, but get several bytes of garbage appended to the end of them (usually, it's a repeat of the last few characters in the file).

If I delete the server files before the upload, it works fine.

I suspect that the File Exists rules are somehow involved, but that still doesn't explain these weird results.

I would be happy with a solution that ALWAYS overwrites the server files.


Hello ...

You can change the file exist rules in the favorite properties. Change all the rules which have the action set to Resume to Overwrite.

To access the file exist rules:
1. menu: Favorites->Edit Favorites
2. Locate your favorite. E.g. in the Quick Connect folder
3. Right-click on the favorite and select Properties
4. Go to the Transfer-File Exist dialog
5. Change the first option to "Use Favorite Settings"
6. Click on the Edit Rules button


Thanks Mat,

Overriding the File Exists properties worked around the problem.

I still think there's a bug in the software because checking for a file's existence shouldn't modify it on the server. Yet I'm definitely seeing the results I described in the first post. The original file is being modified (and corrupted) on the server and it's timestamp is updated to the current time.

Can you post the log which shows the problem? The server might be returning the wrong size of the remote file and SmartFTP tries to resume the file. And that's where the corruption might come from. But that's just a wild guess.


Your wild guess certainly describes exactly what I'm seeing. My client is running Windows XP 64 and the server is Unix. The files are all ASCII, which might account for minor size differences.

I no longer have the log (unless SmartFTP saves them somewhere). Plus, I've changed all my settings as you instructed, so I can't recreate the problem.

I would think that others must be seeing this issue. My host is GoDaddy, which is fairly common.

Here's the connect from the log:

[22:57:10] 230 OK. Current directory is /
[22:57:11] SYST
[22:57:11] 215 UNIX Type: L8
[22:57:11] Detected Server Type: UNIX
[22:57:11] RTT: 85.142 ms
[22:57:11] FEAT
[22:57:11] 211-Extensions supported:
[22:57:11] EPRT
[22:57:11] IDLE
[22:57:11] MDTM
[22:57:11] SIZE
[22:57:11] REST STREAM
[22:57:11] MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
[22:57:11] MLSD
[22:57:11] ESTP
[22:57:11] PASV
[22:57:11] EPSV
[22:57:11] SPSV
[22:57:11] ESTA
[22:57:11] AUTH TLS
[22:57:11] PBSZ
[22:57:11] PROT
[22:57:11] 211 End.
[22:57:11] Detected Server Software: PureFTPd