I cannot access my site with SmartFTP


I cannot access my sites with SmartFTP after I switch my firewall to ZoneAlarm (previously I use F-secure firewall, and it was fine). I have Avirus antivirus as well. Could it possible ZA block my access with smartftp? I remember when I first F-secure, I also have problems to access sites with smartftp, but i change passive mode to active mode, and I access fine. Now when I follow below instruction to try to change to active mode, it is unsuccessful, I can still see "Passive" icon when I try to access my sites:

How To switch between Active / Passive mode

1. Select Favorites > Edit Favorites from the SmartFTP menu. The SmartFTP Favorites window appears.
2. From the SmartFTP Favorites window select the Favorite of interest (check the Quick Connect folder). Right-click on the Favorite and select Properties. The Properties dialog appears.
3. Under the FTP option select Connection. From the Connection tab under Data Connection you can change the Mode to Active Mode (PORT) or Passive Mode (PASV) for the selected Favorite.

What might be gone wrong which causes this problem? How can I fix it?
Also, does anyone knows if I can set permission to sites in ZA?

thanks alot

Yes ZA might be blocking SmartFTP to access the server. Try to add SmartFTP to the exceptions on your software firewall and antivirus product. In some cases you also have to disable the "Worm Protection" in these products.