disable MLST command?

phazei

2009-02-28 02:03:26

This is my log:
[17:30:02] PORT 192,168,1,125,9,19
[17:30:02] 200 PORT command successful.
[17:30:02] STOR .htaccess
[17:30:03] 150 Opening BINARY mode data connection.
[17:30:03] 434 bytes transferred. (28.2 KB/s) (15 ms)
[17:30:03] 226 Transfer completed.
[17:30:03] MFMT 20090228013000 .htaccess
[17:30:03] 213 Modify=20090228013000; .htaccess
[17:30:03] MLST .htaccess
[17:30:06] 500 Syntax error, command unrecognized.
[17:30:06] SIZE .htaccess
[17:30:06] 213 434


It takes 3 seconds to respond with the syntax error, which is a very long time. I either need to get server support for that command, or just not issue it.
I saw the option under FTP to disable MLSD, but is there an option for MLST?

I have another ftp client that doesn't issue that command and transfers are lightning fast on file monitoring.

How can I have it just skip to the next step?

Thanks

mb

2009-02-28 02:23:25

You cannot disable it. Your server should not take 3 seconds to reply to a command it doesn't know. Also I only believe SmartFTP sends the command if the server actually announces it in ithe FEAT list.

Regards,
Mat

phazei

2009-02-28 02:57:19

I checked and the server is NcFTPd which supports the MLSD/MLST commands.
The MLSD command does work.

It is listed in both FEAT and HELP.

Does anyone who might be familiar with NcFTPd know why it would say command not recognized for a MLST command?