Upload file time messed up

suser

2008-12-04 04:57:06

my smartFtp version is v3.0.1024.32.

When i upload a file to my server, it messes up the file time. I just want to see whatever time is displayed in the raw listing. It shows that for a second or so before updating it to some time zone that is neither of my local machine nor of the server. I have tried enabling/disabling 'Keep File Time' under Favourite Properties->Transfer->Files, but that didnt work. I dont see any errors in the log window either.

Here is the raw listing:-

drwxrwxr-x 1 ftp ftp 4096 Dec 03 23:41 .
drwxrwxr-x 1 ftp ftp 4096 Dec 03 23:41 ..
-rwxrwxr-x 1 ftp ftp 613 Dec 03 23:41 abc.txt
drwxrwxr-x 1 ftp ftp 4096 Dec 03 22:14 database
drwxrwxr-x 1 ftp ftp 4096 Nov 14 13:53 logs
-rwxrwxr-x 1 ftp ftp 612 Dec 30 2003 readme.txt
drwxrwxr-x 1 ftp ftp 4096 Nov 26 04:34 synergy
drwxrwxr-x 1 ftp ftp 4096 Nov 14 13:53 www

abc.txt is the file in concern. And the time displayed for it under 'Date Modified' column in smartFTP window is "12/3/2008 3:41 PM"

Any suggestions?

mb

2008-12-04 06:23:02

Can you please post the log from the remote browser? SmartFTP automatically detects the timezone and then displays the time in your local time zone. But you can manually set the server time zone in the favorite properties to manually override this.

suser

2008-12-04 13:08:20

Here is the log from remote browser:
[05:01:58] SmartFTP v3.0.1024.32
[05:01:59] Resolving host name "ftp.silverspaces.com"
[05:01:59] Connecting to 64.34.120.46 Port: 21
[05:02:00] Connected to ftp.silverspaces.com.
[05:02:00] 220 Welcome to our FTP service.
[05:02:00] USER sarahs
[05:02:00] 331 Please specify the password.
[05:02:00] PASS (hidden)
[05:02:00] 230 Login successful.
[05:02:00] SYST
[05:02:00] 215 UNIX Type: L8
[05:02:00] Detected Server Type: UNIX
[05:02:00] RTT: 80.248 ms
[05:02:00] FEAT
[05:02:00] 211-Features:
[05:02:00] AUTH SSL
[05:02:00] AUTH TLS
[05:02:00] EPRT
[05:02:00] EPSV
[05:02:00] MDTM
[05:02:00] PASV
[05:02:00] PBSZ
[05:02:00] PROT
[05:02:00] REST STREAM
[05:02:00] SIZE
[05:02:00] TVFS
[05:02:01] 211 End
[05:02:01] PWD
[05:02:01] 257 "/"
[05:02:01] TYPE A
[05:02:01] 200 Switching to ASCII mode.
[05:02:01] PASV
[05:02:01] 227 Entering Passive Mode (64,34,120,46,216,69)
[05:02:01] Opening data connection to 64.34.120.46 Port: 55365
[05:02:01] LIST -aL
[05:02:01] 150 Here comes the directory listing.
[05:02:02] 506 bytes transferred. (2.64 KB/s) (187 ms)
[05:02:02] 226 Directory send OK.
[05:02:02] MDTM abc.txt
[05:02:02] 213 20081203234100
[05:02:02] Timezone offset: 0 seconds (0.0 hours)


And I also tried changing the server timezone from 'favourite -> properties' and it still doesnt solve the issue. When i upload a file, it shows the correct time zone for just a second or so before it updates it to something of its own. (btw, i didnt have this problem in earlier versions of smartFTP - if that helps)

mb

2008-12-04 16:52:57

Post the log from your upload. To get it:

1. Stop the transfer queue
2. Do the drag&drop operation
3. The item/file appears in the transfer queue
4. Double click the file. The log window opens
5. Start the transfer queue
6. Post the log here

Also please post the corresponding log from the Remote Browser.

suser

2008-12-04 19:22:39

Here is the log from the steps you specified -

[11:17:08] Resolving host name "ftp.silverspaces.com"
[11:17:08] Connecting to 64.34.120.46 Port: 21
[11:17:08] Connected to ftp.silverspaces.com.
[11:17:08] 220 Welcome to our FTP service.
[11:17:08] USER sarahs
[11:17:09] 331 Please specify the password.
[11:17:09] PASS (hidden)
[11:17:09] 230 Login successful.
[11:17:09] SYST
[11:17:09] 215 UNIX Type: L8
[11:17:09] Detected Server Type: UNIX
[11:17:09] RTT: 82.815 ms
[11:17:09] FEAT
[11:17:09] 211-Features:
[11:17:09] AUTH SSL
[11:17:09] AUTH TLS
[11:17:09] EPRT
[11:17:09] EPSV
[11:17:09] MDTM
[11:17:09] PASV
[11:17:09] PBSZ
[11:17:09] PROT
[11:17:09] REST STREAM
[11:17:09] SIZE
[11:17:09] TVFS
[11:17:09] 211 End
[11:17:09] PWD
[11:17:09] 257 "/"
[11:17:09] TYPE I
[11:17:09] 200 Switching to Binary mode.
[11:17:09] PASV
[11:17:09] 227 Entering Passive Mode (64,34,120,46,202,34)
[11:17:09] Opening data connection to 64.34.120.46 Port: 51746
[11:17:09] STOR abc.txt
[11:17:09] 150 Ok to send data.
[11:17:09] 613 bytes transferred. (3.45 KB/s) (173 ms)
[11:17:10] 226 File receive OK.
[11:17:10] MDTM 20081204042005 abc.txt
[11:17:10] 550 Could not set file modification time.
[11:17:10] MFMT 20081204042005 abc.txt
[11:17:10] 500 Unknown command.
[11:17:10] SITE UTIME abc.txt 20081204042005 20081204042005 20081204042005 UTC
[11:17:10] 500 Unknown SITE command.
[11:17:10] SITE UTIME 20081204042005 abc.txt
[11:17:10] 500 Unknown SITE command.
[11:17:10] SIZE abc.txt
[11:17:10] 213 613
[11:17:10] Source File Size = 613, Destination File Size = 613


And log from remote browser:-

[11:14:57] SmartFTP v3.0.1024.32
[11:14:58] Resolving host name "ftp.silverspaces.com"
[11:14:58] Connecting to 64.34.120.46 Port: 21
[11:14:58] Connected to ftp.silverspaces.com.
[11:14:58] 220 Welcome to our FTP service.
[11:14:58] USER sarahs
[11:14:58] 331 Please specify the password.
[11:14:58] PASS (hidden)
[11:14:58] 230 Login successful.
[11:14:58] SYST
[11:14:58] 215 UNIX Type: L8
[11:14:58] Detected Server Type: UNIX
[11:14:59] RTT: 77.904 ms
[11:14:59] FEAT
[11:14:59] 211-Features:
[11:14:59] AUTH SSL
[11:14:59] AUTH TLS
[11:14:59] EPRT
[11:14:59] EPSV
[11:14:59] MDTM
[11:14:59] PASV
[11:14:59] PBSZ
[11:14:59] PROT
[11:14:59] REST STREAM
[11:14:59] SIZE
[11:14:59] TVFS
[11:14:59] 211 End
[11:14:59] PWD
[11:14:59] 257 "/"
[11:14:59] TYPE A
[11:14:59] 200 Switching to ASCII mode.
[11:15:00] PASV
[11:15:00] 227 Entering Passive Mode (64,34,120,46,116,48)
[11:15:00] Opening data connection to 64.34.120.46 Port: 29744
[11:15:00] LIST -aL
[11:15:00] 150 Here comes the directory listing.
[11:15:00] 506 bytes transferred. (2.00 KB/s) (246 ms)
[11:15:00] 226 Directory send OK.
[11:15:00] MDTM abc.txt
[11:15:00] 213 20081203234100
[11:15:00] Timezone offset: 0 seconds (0.0 hours)
[11:15:31] NOOP
[11:15:31] 200 NOOP ok.
[11:15:55] TYPE I
[11:15:55] 200 Switching to Binary mode.
[11:15:55] SIZE abc.txt
[11:15:55] 213 613
[11:15:55] MDTM abc.txt
[11:15:55] 213 20081203234100
[11:15:57] The operation has been added to the Transfer Queue. Check the Transfer Queue for the status.
[11:16:27] NOOP
[11:16:27] 200 NOOP ok.
[11:16:58] NOOP
[11:16:58] 200 NOOP ok.
[11:17:10] SIZE abc.txt
[11:17:10] 213 613
[11:17:10] MDTM abc.txt
[11:17:10] 213 20081204141724
[11:17:10] STAT abc.txt
[11:17:10] 213-Status follows:
[11:17:10] -rwxrwxr-x 1 ftp ftp 613 Dec 04 14:17 abc.txt
[11:17:11] 213 End of status
[11:17:41] NOOP
[11:17:41] 200 NOOP ok.
[11:18:12] NOOP
[11:18:12] 200 NOOP ok.

mb

2008-12-04 20:18:10

Your server does not support the feature to set the file time of a file on the server. Therefore the date of the file on the server is always the date it has been uploaded to.

Regards,
Mat

suser

2008-12-04 20:38:15

So when listing the file, it should show the date/time it has been uploaded on right? That is not happening. I'll be happy if it does that. Like right now, the remote browser shows 6:17 AM for abc.txt. But it was uploaded on 14:17 server time. And raw listing correctly shows -rwxrwxr-x 1 ftp ftp 613 Dec 04 14:17 abc.txt

What can i do to see the same value as shown in raw listing!?

mb

2008-12-04 21:38:09

Set the timezone in the favorite properties to your timezone. But usually date/times are always displayed in local time (e.g. Windows Explorer etc).

Regards,
Mat

suser

2008-12-04 22:37:15

Mat i already tried those options and they havent worked. Am attaching an old screenshot Image

mb

2008-12-08 15:18:36

Please install the latest version from here:
https://www.smartftp.com/download

Then change the timezone settings in the favorite properties. In the old version the timezone settings did not save corectly.

suser

2008-12-08 18:28:36

installed beta - noted the following 2 problems :-

1. When i upload a file from local machine to remote browser window, the file time is displayed correctly (shows my local time zone), BUT file size is shown as 0 bytes

2. Now if i right click in the remote browser window and refresh it, the file size gets corrected, BUT the timezone gets messed up (neither local machine, nor server time zone - shows something of its own)

mb

2008-12-08 19:44:03

Change the time zone (Try Greenwich GMT+0) and try again. It works here as expected.