Have to wait before upload begins

9xb

2008-11-19 16:05:35

+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 3 (Build 2600)

CPU Speed : 3192 MHz
Total Memory : 2038 MB
Free Memory : 1184 MB

+- SmartFTP ---------------------------
Version : 3.0.1024.27
Time Stamp : 2008-11-18 12:57:36
Platform : x86
Id : 400068428
Days in use : 530

+- Application DLL --------------------
sfFTPLib.dll : 1.5.15.3
sfFavorites.dll : 1.0.20.27
sfFavoritesShellExtension.dll : 1.0.1.20
sfTransferQueue.dll : 1.0.17.27
sfFTPShellExtension.dll : 1.0.15.27
SmartFTPPS.dll : 3.0.1024.27

+- Language ---------------------------
SmartFTP.exe : 3.0.1024.27

+- Internet Explorer ------------------
Version : 7.0.5730.11

+- Winsock ----------------------------
Winsock : 2.2

Often when trying to upload a file I'm working on (I have it open in another application) it will not upload immediately - immediately says "Retry at xx:xx:xx" and I have to wait up to a minute for the file transfer to commence.

Can you let me know you're looking into this?

Thanks!

mb

2008-11-19 16:46:59

Double click the file in the transfer queue window. The log window opens. Copy&Paste the log here.

9xb

2008-11-20 09:23:07

[09:22:57] CWD /httpdocs/pages/home
[09:22:57] 250 CWD command successful
[09:22:57] PWD
[09:22:57] 257 "/httpdocs/pages/home" is current directory.
[09:22:57] Remote file exist check: "homeuk.inc.php".
[09:22:57] SIZE homeuk.inc.php
[09:22:57] 213 3155
[09:22:57] MDTM homeuk.inc.php
[09:22:57] 213 20081120092232
[09:22:57] Source File: Size=3156, SizeUnit=Byte, Time=2008-11-20T09:22:50, TimeFormat=Exact
[09:22:57] Destination File: Size=3155, SizeUnit=Byte, Time=2008-11-20T09:22:32, TimeFormat=Exact
[09:22:57] RecentTime=2008-11-20T09:22:57
[09:22:57] Rule "IF Destination Time=Recent AND Size=Smaller AND Transfer=No Matter THEN Resume" matched. Action="Resume".
[09:22:57] PASV
[09:22:57] 227 Entering Passive Mode (89,234,2,218,232,189).
[09:22:57] Opening data connection to 89.234.2.218 Port: 59581
[09:22:57] REST 3155
[09:22:57] 350 Restarting at 3155. Send STORE or RETRIEVE to initiate transfer
[09:22:57] STOR homeuk.inc.php
[09:22:57] 451 homeuk.inc.php: Append/Restart not permitted, try again
[09:22:57] 0 bytes transferred. (0 bytes/s) (15 ms)
[09:22:57] Restart not permitted. Overwriting the file.
[09:22:57] Transfer failed.

mb

2008-11-20 12:39:31

Your server does not support resume. Therefore SmartFTP will overwrite the file on the next transfer attempt. Are you uploading the file in binary/auto mode?

Regards,
Mat

9xb

2008-11-20 12:58:27

Hi Mat, yes I'm using AUTO mode - what should I do?

Thanks!

mb

2008-11-20 13:12:44

Contact your server administrator and ask them to enable resume.

9xb

2008-11-20 13:19:12

Hi Mat, I don't have this problem with any other FTP software - are there any settings within SmartFTP that would stop it from requiring resume?

mb

2008-11-20 13:22:18

Please post the log from the other FTP product you are using. You also have to post a log from a failed transfer otherwise we cannot compare the behavior.

9xb

2008-11-20 13:25:49

Hi Mat, I don't have any installed on this workstation so I'm not able to do that right now. It's a problem that's only recently come to light, are you sure there's no way of getting round this?

Also, why is it trying to resume at all? I just want to overwrite the file.

mb

2008-11-20 13:30:56

You can override the file exist rules and tell SmartFTP to always overwrite your files (this is not recommended).

9xb

2008-11-20 14:09:04

Hi Mat, why is this not recommended?

Also I can't see an option to edit the "File Exists" settings in Tools > Settings?

mb

2008-11-20 14:17:08

1. menu: Favorites->Edit Favorites
2. Locate your favorite. Look in the Quick Connect folder
3. Right-click on the favorite. Select Properties
4. Go to the Transfer->File Exist dialog
5. Change the option to "Use Favorite Settings:
6. Click on the Edit button
7. Change the rules

9xb

2008-11-20 14:41:06

Hm that's going to take a long time, why is it not recommended?

Plus, in that dialogue it has an option for "use default settings" - where are the default settings... set?

Thanks

mb

2008-11-21 12:54:29

Try the latest version:
https://www.smartftp.com/download

It has a work-around for your server's problem.

9xb

2008-11-21 13:13:33

Wow that's awesome! Thanks very much for your help!

mb

2008-11-21 13:21:48

Did it work as expected?