Using HTTP proxy.

Grimwiz

2008-10-01 10:51:38

We have a FTP proxy. Tested to be working fine with FileZilla.

The logs below indicate that we have correctly set the proxy IP as 10.45.162.46 on port 21, but SmartFTP is trying to connect to port 80.

Unsurprisingly, this fails.

[11:39:35] Resolving host name "10.45.162.46"
[11:39:35] Proxy: Resolving host name 10.45.162.46
[11:39:35] Connecting to 10.45.162.46 Port: 21
[11:39:35] Proxy: Connecting to HTTP proxy server 10.45.162.46 Port: 80
[11:39:36] No connection could be made because the target machine actively refused it.
[11:39:36] Client closed the connection.
[11:39:36] Connect failed. Waiting to retry (30s)...

Please can you either point me at the setting that is wrong, or help me with a fix. We are using version v3.0.1012.17

Tim Towers

mb

2008-10-01 15:47:26

You have setup a HTTP proxy. What you need is to set the FTP proxy in the FTP->Connection->Proxy dialog instead.

Regards,
Mat

Grimwiz

2008-10-06 12:50:43

You have setup a HTTP proxy. What you need is to set the FTP proxy in the FTP->Connection->Proxy dialog instead.

Regards,
Mat

In my default Favourite Properties, the settings are as follows:
Type: USER user@host
Host: 10.45.162.46
Port: 21

Unfortunately your information was only of limited use... However, it did lead me to look in Propterties->Connection->Proxy where I was able to remove the HTTP proxy and get it to work.