Remote files automatically go to transfer Queue

cognecy

2008-09-16 19:25:18

Have used SmartFTP for years and just purchased my professional license.

NOTE: Since every support response starts with telling the customer to load the most recent version, let me get this out of the way by saying that I have the most recent version installed already.

Problem: With the latest version of Smart FTP I noticed that just clicking on a file (just to select it) automatically adds that file to the Transfer Queue. This is really bothersome because I transfer large groups of files to and form my local machine for my ecommerce application and lately I am getting files end up in the wrong directory because of this new feature/annoyance. None, and I repeat None of the versions of Smart FTP prior to a few months ago did this.

I want to have complete control over what goes into the transfer queue (as I am sure others do as well). How do I turn this annoyance off?

What I have done so far:

1) removed any preset editors in Settings --> Remote Edit
2) in Settings --> Navigation I have set 'Double Click Action' to none.

Beyond that, I have been through every other menu in the settings dialog and cannot find anything that even remotely relates to this Automatic adding to the Transfer Queue problem.

mb

2008-09-16 19:39:00

Maybe you have the double click action set to "Add to Queue"? Go to the menu: Tools->Settings. Then go to the General->Navigation dialog and check your double click action.

Regards,
Mat

cognecy

2008-09-16 20:09:52

In my post I mentioned that I have set 'Double Click' to none and that is what it is set to.

Regardless of the Double Click action, I am not double clicking. I am simply selecting a file in same maner that you do to change focus on a window element. For instance: I have my local browser on the left and my remote browser on the right. When changing my cursor focus to the remote browser I need to click in the file section somewhere so I can scroll to the files I need. When I click in the remote file area (Single click) if I happent to click on a file, it automatically adds it to the transfer cue instead of allowing me to drag it there myself.

This behavior is wrong and should not do that. None of the previous versions of SmartFTP prior to a month or two ago did this.

I have completely reloaded SmartFTP with the latest version (prior I uninstalled the application completely form the core files and the registry). On the re-install it was still exhibiting the same behavior.

mb

2008-09-16 21:52:51

There is a bug with the double click action on SmartFTP. Even if you set it to None it adds it to the transfer queue. This will be fixed by tomorrow.

However a single click should not result in a double click. I think there is setting in Windows to enable double click on a single click. You can it as following:
Open a folder window. (It can be any folder.)
Look at the top, where the menu is, and click the "Tools" menu.
In the Tools menu, click "Folder Options."
In the section called "Click items as follows," choose "Single-click to open an item (point to select).
Click "OK" to confirm your choice and close the window.


Regards,
Mat

cognecy

2008-09-17 03:34:09

Well I have always been good at finding bugs in software applications.

As far as the Double click/Single click action that is set by windows I am aware of it but it should not make any difference to a software application (I think you can agree there). The application should know the difference and accommodate for that setting regardless. Now that your software is officially a commercial user software, you cannot expect your users to change their operating system user preferences for the sake a an FTP software client. (just advice from a CEO of an IT services company in case you were wondering). From my experience, I can tell you that once your free users have to start paying, they tend to tolerate less and less by way of discrepancies and their loyalties are now also for sale. Take it for what it is worth. You guys have been at this for 10+ years now so I know you are up for the task.

I will look for and anticipate a patch.

Thanks for working with me on this. I have to tell you that after using the software for several years as a free user knowing that the support was basically limited to just a forum, I was very hesitant to purchase it. My thinking was that nothing was going to change and the support would just not be there. This experience is setting my mind at ease and I definitely feel better about the decision to purchase and sticking with a product that I know and trust. The only suggestion I have would be to add in 24/7 phone support for users that purchase the support contract (myself I purchased the 3 year plan).

mb

2008-09-17 09:23:06

The instructions how to disable the single click on item was given as a workaround until the bug has been fixed.

We also offer technical support through email and we always did. If you would like 24/7 phone support the product cost would be 100-200 USD and not 50 USD as it is now.

Regards,
Mat

mb

2008-09-17 13:34:49

Try the latest version:
https://www.smartftp.com/download

If the double click action is set to None the "Enter" key will have no effect as well. If you want the same behavior as in Windows Explorer set the double click action to "Default".

Regards,
Mat

cognecy

2008-09-17 17:11:23

Not much has changed with this issue. THe system still automatically places items in the transfer queue when changing focus from the local to the remote window. Now it is even automatically launching items in the local window as well.

Here is a link to a screen video (with audio) that shows what I am experiencing.

http://www.cognecy.com/files/AutoQueueProblem.zip (it is a swf file)

I think what need to happen is to disable this feature all together and force it 'drag and drop' to the transfer queue. If you want to edit a file there is nothing wrong with right clicking on it an selecting edit. With this solution you would likly soll all the transfer queue issues.

mb

2008-09-17 19:00:44

The fix didn't make it into the latest build. Please try the newest version:
https://www.smartftp.com/download

The reason why your files open on a single click in the Local Browser is because you have set the option this way. To change it:
1. Open a folder window. (It can be any folder.)
2. Look at the top, where the menu is, and click the "Tools" menu.
3. In the Tools menu, click "Folder Options."
4. In the section called "Click items as follows," choose "Double-click to open an item (single click to select).
5. Click "OK" to confirm your choice and close the window.

The "Double-click to open an item" is selected by default on a new installation of Windows.

Regards,
Mat

cognecy

2008-09-17 19:52:43

so is the patch in the current version now?

I am aware of how to change the XP setting for the operating system (remember I am the CEO of an IT services company). I have had this set to single click as long as this option was available in Windows. BUT.... this does not and never has affected changing focus on open windows with SmartFTP. Now with SmartFTP, you are effectively displaying multiple windows within the GUI. But the point really is that it simply should not automattically add things to the transfer queue.

Again you are still asking the user to change their operating system user experience for the sake of one application. This is just not good programming practice. To further illustrate my point, as I have mentioned before, SmartFTP did not have this issue before in previous versions. Something changed in the last couple builds of the sofware that made it start doing this.

mb

2008-09-17 19:59:08

The fix for the Remote Browser is in the latest version.