Problem of SmartFTP Freezing Up

Hi - I've recently changed to using MS-Vista. Since doing so I'm experiencing a number of problems using SmartFTP. I've reinstalled SmartFTP and tried upgrading to the latest build (3.0.1022.15). Basically the problem appears to be something to do with the local browser window. Whenever I try and create a new folder or 'right click' a file in the local browswer window the SmartFTP program freezes. I thought it might be something to do with MS-Vista security settings but can't find any setting which seems to solve the problem; alternatively something to do with not running SmartFTP in 'Administrator Mode' but while this is possible for some applications the option doesn't appear to be available for SmartFTP. Would be grateful for any ideas of how to solve this problem. I suspect it is something to do with upgrading to Vista but for some reason simply reinstalling the SmartFTP software doesn't solve the problem - many thanks in anticipation of your response.

Update ... I've tried a clean install and deleting the SmartFTP reg entry (per other suggested fixes for Freezing problems) but the problem remains --> If I 'right click' a file, or try and create a new folder, in the local browser window SmartFTP freezes up. Would welcome any suggestions or ideas about fixing this problem. I've got used to using SmartFTP over the years and would like to continue using it with Vista. Many thanks.

Try to run SmartFTP under a different user account.

Try to run SmartFTP under a different user account.

Thanks for this suggestion - it worked!

Is there a way of making it work in my current account or do I need to migrate all my activities to a new account? It seems strange this should happen - perhaps there is some registry entry that needs to be removed or updated?

Any ideas or suggestions would be much appreciated - thanks.

You can try the ShellExView tool:

Disable all shell extensions (not the one from Microsoft and SmartFTP) until you find the one that causes the problem. I would start disabling the "Context Menu" handlers.