SmartFTP does not show all directores

cvandermeij

2008-08-22 10:19:13

My SmartFTP does not display all the directories in the httpdocs folder of ftp.effectmeting.nl However the directories that do not show up are visible in Filezilla, a free FTP client. This happens on multiple computers on different networks. Is this a common issue? I have not found anything related to this problem.

Thanks,
Chiel

mb

2008-08-22 14:55:36

Post the log from filezilla and SmartFTP.

And then post the raw directory listing from the httpdocs folder. To get it right click on the folder and select "Show Raw Listing"

cvandermeij

2008-08-23 11:48:51

The SmartFTP log:

[13:46:04] SmartFTP v3.0.1022.4
[13:46:20] Resolving host name "ftp.effectmeting.nl"
[13:46:20] Connecting to 174.133.212.250 Port: 21
[13:46:20] Connected to ftp.effectmeting.nl.
[13:46:20] 220 Microsoft FTP Service
[13:46:20] USER effectmeting.nl
[13:46:20] 331 Password required for effectmeting.nl.
[13:46:20] PASS (hidden)
[13:46:20] 230 User effectmeting.nl logged in.
[13:46:20] SYST
[13:46:21] 215 Windows_NT
[13:46:21] Detected Server Type: Windows NT
[13:46:21] FEAT
[13:46:21] 211-FEAT
[13:46:21] SIZE
[13:46:21] MDTM
[13:46:21] 211 END
[13:46:21] TYPE I
[13:46:21] 200 Type set to I.
[13:46:21] REST 0
[13:46:22] 350 Restarting at 0.
[13:46:22] PWD
[13:46:22] 257 "/" is current directory.
[13:46:22] CWD /httpsdocs
[13:46:22] 250 CWD command successful.
[13:46:22] PWD
[13:46:22] 257 "/httpsdocs" is current directory.
[13:46:22] TYPE A
[13:46:22] 200 Type set to A.
[13:46:22] PASV
[13:46:23] 227 Entering Passive Mode (174,133,212,250,19,235).
[13:46:23] Opening data connection to 174.133.212.250 Port: 5099
[13:46:23] LIST -aL
[13:46:23] 125 Data connection already open; Transfer starting.
[13:46:23] 51 bytes transferred. (265 bytes/s) (192 ms)
[13:46:23] 226 Transfer complete.

The SmartFTP raw listing:

07-07-08  11:59AM	   <DIR>		  _private

07-07-08  11:59AM	   <DIR>		  _vti_cnf

07-07-08  11:59AM	   <DIR>		  _vti_log

07-07-08  11:59AM	   <DIR>		  _vti_pvt

07-07-08  11:59AM	   <DIR>		  _vti_script

07-07-08  11:59AM	   <DIR>		  _vti_txt

08-06-08  05:47PM				99549 aanvraag.asp

08-06-08  05:47PM			   368640 aanvraag.mdb

08-06-08  05:47PM			   149409 aanvraagportal.asp

07-07-08  11:59AM	   <DIR>		  App_Data

07-07-08  03:44PM	   <DIR>		  aspnet_client

08-06-08  05:47PM				  127 cal.gif

08-06-08  05:47PM				 6638 calendar.html

08-06-08  05:47PM				 6409 calendar1.js

08-06-08  05:47PM				 6373 calendar2.js

07-07-08  03:44PM	   <DIR>		  cgi-bin

08-06-08  05:47PM				 1052 clock_000.gif

08-06-08  05:47PM				 1030 clock_005.gif

08-06-08  05:47PM				  995 clock_010.gif

08-06-08  05:47PM				  975 clock_020.gif

08-06-08  05:47PM				  953 clock_025.gif

08-06-08  05:47PM				  964 clock_030.gif

08-06-08  05:47PM				  958 clock_035.gif

08-06-08  05:47PM				  917 clock_040.gif

08-06-08  05:47PM				  928 clock_045.gif

08-06-08  05:47PM				  927 clock_050.gif

08-06-08  05:47PM				  924 clock_055.gif

08-06-08  05:47PM				  929 clock_060.gif

08-06-08  05:47PM				  918 clock_065.gif

08-06-08  05:47PM				  933 clock_070.gif

08-06-08  05:47PM				  953 clock_075.gif

08-06-08  05:47PM				  909 clock_080.gif

08-06-08  05:47PM				  910 clock_085.gif

08-06-08  05:47PM				  912 clock_090.gif

08-06-08  05:47PM				  944 clock_095.gif

08-06-08  05:47PM				  913 clock_100.gif

07-07-08  03:44PM	   <DIR>		  Connections

08-06-08  05:47PM				 4551 conrad.jpg

08-06-08  05:47PM				11782 counter.swf

07-07-08  03:44PM	   <DIR>		  css

08-23-08  11:53AM	   <DIR>		  db

07-07-08  03:49PM	   <DIR>		  demo

07-07-08  03:51PM	   <DIR>		  demopapendal

08-06-08  05:47PM				 7787 error_401.asp

08-06-08  05:47PM				33930 FC2Column.swf

08-06-08  05:47PM				 9162 FC2Pie3D.swf

07-07-08  04:19PM	   <DIR>		  film

08-06-08  05:47PM			   121102 footer.swf

08-06-08  05:47PM				37696 footer.xlf

08-06-08  05:47PM				  104 footer.xml

08-06-08  05:47PM				 8147 ggn.asp

08-07-08  01:51PM	   <DIR>		  gom

08-06-08  05:47PM				  608 helpinfo.gif

08-07-08  04:53PM	   <DIR>		  images

07-07-08  11:59AM	   <DIR>		  img

08-06-08  05:47PM				  125 index.html

08-06-08  05:47PM
The Filezilla log:

Status: Connecting to 174.133.212.250:21...
Status: Connection established, waiting for welcome message...
Response: 220 Microsoft FTP Service
Command: USER effectmeting.nl
Response: 331 Password required for effectmeting.nl.
Command: PASS *********
Response: 230 User effectmeting.nl logged in.
Command: SYST
Response: 215 Windows_NT
Command: FEAT
Response: 211-FEAT
Response: SIZE
Response: MDTM
Response: 211 END
Status: Connected
Status: Retrieving directory listing...
Command: CWD /httpdocs/wordpress/wp-content/themes/effectmeting 1/
Response: 250 CWD command successful.
Command: PWD
Response: 257 "/httpdocs/wordpress/wp-content/themes/effectmeting 1" is current directory.
Command: TYPE I
Response: 200 Type set to I.
Command: PASV
Response: 227 Entering Passive Mode (174,133,212,250,19,237).
Command: LIST
Response: 125 Data connection already open; Transfer starting.
Response: 226 Transfer complete.
Status: Directory listing successful

cvandermeij

2008-08-23 11:56:00

Here is the screenshot of the Filezilla httpdocs folder:

http://www.effectmeting.nl/screenshot.jpg

You see that in the screenshot of Filezilla, there are much more folders displayed then in the Smart FTP program.

mb

2008-08-23 12:17:26

Can you email us the raw directory listing and tell us which folders exactly are not displayed in SmartFTP?

cvandermeij

2008-08-24 08:57:38

Can you email us the raw directory listing and tell us which folders exactly are not displayed in SmartFTP?

To what e-mail address do I need to send it?

mb

2008-08-24 09:10:00

support at smartftp.com

Thanks

cvandermeij

2008-08-24 20:16:13

We just got the issue resolved. Here is the solution.

You need to remove the –aL arguments from the LIST command and try again. See the folowing link for instructions how to do it:
https://www.smartftp.com/support/kb/how- ... -f137.html

Thanks for your help!

mb

2008-08-24 20:24:09

If this is a common issue on Windows_NT FTP servers we can programmatically remove the -aL arguments. So please post here if you are also affected by this problem.

Thank you.