Question w/ scheduled transfers for remote folders


We are using SmartFTP to download surveillance videos from a remote server. There are 4 folders we are "monitoring" remotely for new files using the "Schedule" transfer feature - set to 1 minute. SmartFTP always rescans the folder when a worker is available before completely processing it's current transfer list. We found that moving the watched folder to the bottom of the list resolves our problem - unfortunately we can't figure out how to get SmartFTP to do this automatically.

Also wondering if we can assign two workers to each folder - right now we are running 4 instances of SmartFTP, each watching a different folder. Any advice would be greatly appreciated.


Brian /w

Hello ..

I do not understand your first question but for the 2nd part try to setup SmartFTP as following:
1. Locate your favorite. Menu: Favorites->Edit Favorites. Then right-click on the favorite and select Properties from the context menu. Then in the Transfer->Queue dialog set the number of workers to 2.
2. Then create 3 copies (for a total of 4) of the favorite item you just edited. Name the 4 favorites as following: Favorite Name #1, Favorites Name #2, etc.
3. Connect to each of your favorite
4. Add to the folder to the transfer queue and set it to monitor
5. Set the number of workers in the transfer queue to 8 (4x2)

Now each favorite will exactly use 2 workers. This way you only have to start 1 instance of SmartFTP.


Awesome - that should work perfectly.

I'll try my first question again.

How do you get SmartFTP to completely process a folder with recurrence enabled BEFORE re-processing the folder?

Let's say my remote folder (the one we are watching for new files) has 50 items and it takes 4 minutes to process it (without downloading anything) and my recurrence is set to 1 minute. I want SmartFTP to process the 50 items before it initiates a recurrence on the root folder.

The way it works now - SmartFTP starts processing the list of 50 items, it goes through it for 1 minute, then rescans the root folder and adds the contents of the entire foler (the one we are watching for new files) to the transfer list. The rest of the list it was processing is then added to the end of it's new list...hence rescanning things multiple times before finishing it's first "recurrence."

Or - how do we get SmartFTP to always put the folder with "Recurrence" on it to the bottom of the transfer list?

My apologies if this isn't clear, tried just about everything including grouping but can't seem to get the desired result. I could change the recurrence time to like half hour but we need it set to 1 minute so that new files are downloaded as quickly as possible.

Thanks for your help,

Brian w/

Hello ..

You have to set the recurrence interval to a higher value than what the scanning of the all folders takes. Otherwise you will end up with more items in the transfer queue that can ever be processed. So in your case set the recurrence interval to 5-10 minutes depending how long the scanning of the folders take.


Okay thanks - was hoping there was a different answer but that will work. I would like to mention that it appears SmartFTP could do what I'm asking. When using the MOVE method for Syncrhonizing remote folders to local, SmartFTP mentions "Waiting for Child objects to finish" on the parent folder. If this feature was implemented to the Schedule tab for file transfers that would be awesome. Anyways thanks for all your help. Great product btw.

Brian w/