Is there really no way to disable Transfer Queue

sparkster500

2008-08-05 18:57:16

Hi,

I upgraded to the latest version two days ago and I am really just not getting on with the Transfer Queue. Everything feels much more clunky now and I feel that it slows me down working.

I use SmartFTP constantly throughout the day and I really loved the simple drag and drop and seeing the files transferring in the log. The transfer queue just does not feel the same.

From what I've read this feature cannot be disabled - is that true? Is there some kind of hidden config setting or registry key that can be changed or I am better of just uninstalling and downgrading to version 2.5?

Thanks

mb

2008-08-05 19:17:31

Hello ..

No it cannot be disabled since we strongly believe it is a good thing.

If there are no files left in the transfer queue you can assume that they have all been transferred successfully. It means you don't need to manually supervise the transfers anymore.

Regards,
Mat

sparkster500

2008-08-05 19:23:59

Thanks for your quick reply.

I can see it being a good thing for large uploads (ie upload a whole site), but I mostly am just uploading a single HTML or PHP file and the transfer queue takes 3 or 4 seconds to connect and upload. This seems silly when I already have a connection for the remote browser. It may only be a few seconds, but it just feels so much more awkward to use now.

It really would be nice to be able to disable this feature, but if this is not possible as you say then I will go back to 2.5

mb

2008-08-05 19:31:09

Hello ..

It only takes 3-4 seconds for the connection to be established for the first file you put into the queue. Then the connection will be reused even if you add some files minutes later to the transfer queue. For example if you use the remote edit function there is no delay because the connection is already open from the previous transfer.

Regards,
Mat

sparkster500

2008-08-05 19:55:50

Yes, but it's still 3-4 seconds more than I had with version 2.5.

Also, because you are then not using the remote browser anymore for the transfer that closes after 5 minutes. When you come back to upload a file you have to wait for the remote browser to connect to check for conflicts even though you already have a connection open for the transfer queue, so again you lose time.

It may only be seconds, but when you are using this the whole working day it does add up.

As you say it cannot be disabled and you have no plans to allow it to be disabled, so I wouldn't worry about it. I have no problems going back to 2.5, as that is a fantastic piece of software and I think still the best FTP client I have used.

Thanks anyway.

mb

2008-08-05 20:01:08

Hello ..

You can add some additional commands to the keep alive command list (e.g. LIST) to prevent the remote browser connection from being dropped. To add the commands go to the Favorites Properties. Then go to the FTP->Connection->Keep Alive dialog.

Alternatively there is a dialog displayed while the Remote Browser checks if the file exists on the server. This dialog has a button called "Use Automatic Rules". When you click it the check is aborted and the item is directly processed in the transfer queue.

Regards,
Mat

LordX

2008-08-27 21:09:13

No it cannot be disabled since we strongly believe it is a good thing.

Yes , this is a good thing when you need it.
but how about if I have only 1 login slot to FTP server?
when Transfer Queue trying to connect and uploda a file it just can't because I am useing my 1 connection in the main window, in this case SmartFTP is useless.
Please give us choice!
I must have main window transfere option too , not just on Transfer Queue.
Thanks,
Bye.

mb

2008-08-27 21:19:24

Hello ..

There is a workaround:
https://www.smartftp.com/support/kb/421- ... f2602.html

I'm not sure why a web hosting provider would have a 1 concurrent connection limit. This limit is usually in place for free web hosting plans to encourage users to upgrade to a paid web hosting plan.

Regards,
Mat

LordX

2008-08-27 22:10:09

mb

2008-08-27 22:14:38

Why doesn't the workaround not work for you? Just disconnect the Remote Browser before you start the Transfer Queue?

Oh yeah we all know what you are referring to with the "private FTP servers" :-)

Regards,
Mat