Transfer Queue

Razorwing

2008-07-25 11:25:24

Hello,

I am having two problems with SmartFTP and i am sure its down to user error (me).

Main use: I typically use SmartFTP to transfer SQL Backups from a server to a backup location, so I have several queues which are executed at scheduled times of the day, everyday (out of business hours). The current settings for queue is on startup remember last queue state and on completion, idle.

First Problem - Within the event logs of the server, i get warning that the ftp connection idled for 120seconds and was forced to disconnect. Is there any way to get SmartFTP to automaticlly disconnect after queue transfer?

Second Problem - I think this is related to the first problem, e-mails are not sent for completed or failed transfer attempts, i think this is because the queue is still active even though the transfer is complete and thus does not send an e-mail until the queue has stopped. I have attempted to set queue complete option to stop queue and this allows the automated e-mails to be sent but the scheduled tasks do not run as they are not in an active state (start icon is highlighted).

Any help would be greatful.

Regards,
Andrew

mb

2008-07-25 15:32:37

>First Problem - Within the event logs of the server, i get warning that the ftp connection idled for 120seconds and was forced to disconnect. Is there any way to get SmartFTP to automaticlly disconnect after queue transfer?
No this is not possible. The connections are left open because they might be reused later. But they are closed by the server anyway after some time.

>Second Problem
Failed transfers are transfers that fail after the retry count reaches the max retry (default max retry: unlimited). I'm unable to reproduce the problem with the completed transfers.

Regards,
Mat

Razorwing

2008-08-01 10:18:27

Thank you for replying back so quickly.

Second Problem: I think you misunderstood me, no e-mails are sent at all after a queue is complete even though its setup correctly to do so (After transfer complete, idle, send success or failed messages). I am not sure why no e-mails are sent after a queue is completed.

mb

2008-08-01 10:29:26

Did you send a test email in the menu: Tools->Settings Queue->Email dialog?

Regards,
Mat

Razorwing

2008-08-01 11:28:40

Yes, that worked successfully. If i set "On Queue Complete" to "Stop Queue" it send the e-mails but by doing this, it will not automatically run the queues i scheduled so the current status is set to idle.

mb

2008-08-01 11:33:07

I'm sorry but I'm unable to reproduce it. What I did is the following:

- Queue was already started
- On Queue Complete is set to "Idle"
- Email->On Transfer Queue is enabled
- Now I uploaded one file to the server.
- The queue processes the item and sends the email at the end.

Can you post the system information from the menu: Help->About "System Information" dialog.

Regards,
Mat

Razorwing

2008-08-01 12:05:36

+- System -----------------------------
Microsoft Windows Server 2003 "R2" Standard Edition
Service Pack 2 (Build 3790)

CPU Speed : 1995 MHz
Total Memory : 2047 MB
Free Memory : 734 MB

+- SmartFTP ---------------------------
Version : 3.0.1021.3
Time Stamp : 2008-07-25 06:09:54
Platform : x86
Id : 400052123
Days in use : 346

+- Application DLL --------------------
sfFTPLib.dll : 1.5.13.38
sfFavorites.dll : 1.0.17.3
sfFavoritesShellExtension.dll : 1.0.1.13
sfTransferQueue.dll : 1.0.14.3
sfFTPShellExtension.dll : 1.0.12.3

+- Language ---------------------------
SmartFTP.exe : 3.0.1021.3

+- Internet Explorer ------------------
Version : 7.0.5730.11

+- Winsock ----------------------------
Winsock : 2.2

Razorwing

2008-08-08 10:48:27

Any suggestions on what the problem may be or is there any more information i can provide to help?

Regards,
Andrew

mb

2008-08-08 16:23:41

Please install the latest version from:
https://www.smartftp.com/download

For more details about the email notification open the log in the transfer queue.

Regards,
Mat

Razorwing

2008-08-13 14:50:36

Thank you, i have upgraded to the latest version and everything seems to be working much better.

I am now able to send e-mails successfully without any problems, not sure what you have done but thank you