Problem with FTP over SSL Explicit

Mavol

2008-06-28 13:12:20

When using the protocol FTP over SSL Explicit I can login but SmartFTP always gets stuck on the MLSD command, and eventually times out. I also tried disabling MLSD so LIST is used but same problem there.

I tried repairing the SmartFTP installation but to no avail. All settings are left at their default setting. I also tried connecting without my router, so with a direct cable connection to the internet but that didn't change anything.

The problem is not server related since I rent my own server and had everything checked, it seems only the owner can't login
I can however login using normal FTP, but would like the layer of extra security.

These are my login settings:
Image

Here's the log:
[15:09:48] SmartFTP v3.0.1019.0

[15:09:49] Resolving host name "67.228.5.228"

[15:09:49] Connecting to 67.228.5.228 Port: 21

[15:09:49] Connected to 67.228.5.228.

[15:09:49] 220---------- Welcome to Pure-FTPd [TLS] ----------

[15:09:49] 220-You are user number 2 of 50 allowed.

[15:09:49] 220-Local time is now 08:03. Server port: 21.

[15:09:49] 220-IPv6 connections are also welcome on this server.

[15:09:49] 220 You will be disconnected after 30 minutes of inactivity.

[15:09:49] AUTH TLS

[15:09:49] 234 AUTH TLS OK.

[15:09:49] Connected. Exchanging encryption keys...

[15:09:50] Session Cipher: 128 bit AES

[15:09:50] TLS encrypted session established.

[15:09:50] PBSZ 0

[15:09:50] 200 PBSZ=0

[15:09:50] USER showip

[15:09:50] 331 User showip OK. Password required

[15:09:50] PASS (hidden)

[15:09:50] 230-User showip has group access to:  showip  

[15:09:50] 230 OK. Current restricted directory is /

[15:09:50] SYST

[15:09:51] 215 UNIX Type: L8

[15:09:51] Detected Server Type: UNIX

[15:09:51] FEAT

[15:09:51] 211-Extensions supported:

[15:09:51]  EPRT

[15:09:51]  IDLE

[15:09:51]  MDTM

[15:09:51]  SIZE

[15:09:51]  REST STREAM

[15:09:51]  MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;

[15:09:51]  MLSD

[15:09:51]  ESTP

[15:09:51]  PASV

[15:09:51]  EPSV

[15:09:51]  SPSV

[15:09:51]  ESTA

[15:09:51]  AUTH TLS

[15:09:51]  PBSZ

[15:09:51]  PROT

[15:09:51] 211 End.

[15:09:51] Detected Server Software: PureFTPd

[15:09:51] PWD

[15:09:51] 257 "/" is your current location

[15:09:52] TYPE A

[15:09:52] 200 TYPE is now ASCII

[15:09:52] PROT P

[15:09:52] 534 Fallback to [C]

[15:09:52] PROT C

[15:09:52] 200 OK

[15:09:52] PASV

[15:09:52] 227 Entering Passive Mode (67,228,5,228,66,217)

[15:09:52] Opening data connection to 67.228.5.228 Port: 17113

[15:09:52] MLSD

[15:10:13] A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.

+- System -----------------------------

Microsoft Windows Vista Home Premium Edition 

Service Pack 1 (Build 6001)



CPU Speed		   : 3733 MHz

Total Memory		: 2047 MB

Free Memory		 : 1046 MB



+- SmartFTP ---------------------------

Version			 : 3.0.1019.0

Time Stamp		  : 2008-06-27 05:05:11

Platform			: x86

Id				  : 400048035

Days in use		 : 254



+- Application DLL --------------------

sfFTPLib.dll		: 1.5.13.32

sfFavorites.dll	 : 1.0.15.0

sfFavoritesShellExtension.dll : 1.0.1.13

sfTransferQueue.dll : 1.0.12.0

sfFTPShellExtension.dll : 1.0.10.0



+- Language ---------------------------

SmartFTP.exe		: 3.0.1019.0



+- Internet Explorer ------------------

Version			 : 7.0.6001.18000



+- Winsock ----------------------------

Winsock			 : 2.2

mb

2008-06-28 13:44:02

Try to switch to FTP (non secured) instead of FTP over SSL.

Regards,
Mat

Mavol

2008-06-29 15:17:10

I want to stick to a more secure protocol; I tried SFTP over SSH and I can connect just fine which is great, however there is a new problem:

I am unable to correctly upload any files with a .php extension.

The upload is completed and everything seems alright, but when I try to view the file in my browser all I get is a 500 error. The strange thing is this only occurs when I upload files with a .php extension, other files will upload and display just fine. The actual content of the file is irrelevant.
If I upload the file first with a different file extension and then change it to .php, I still get the 500 error.

This is the error message I see in my browser:

Image

I tried repairing the SmartFTP installation again and also tried without my router --using a direct internet connection, but this did not help, again.
All SmartFTP settings are set to default and this is what I use to login:

Image

This is the actual log:

[14:34:19] SmartFTP v3.0.1019.0

[14:34:20] Resolving host name "67.228.5.228"

[14:34:20] Connecting to 67.228.5.228 Port: 22

[14:34:20] Starting SSH session. Remote Id: "SSH-2.0-OpenSSH_4.3"

[14:34:20] Initiating key exchange.

[14:34:21] Computing session key.

[14:34:21] Key Exchange Algorithm: diffie-hellman-group-exchange-sha1

[14:34:21] Key exchange completed.

[14:34:21] Host Key Algorithm: ssh-rsa

[14:34:21] Client to Server Encryption: aes256-ctr

[14:34:21] Server to Client Encryption: aes256-ctr

[14:34:21] Session HMAC: hmac-sha1

[14:34:21] Client to Server Compression: none

[14:34:21] Server to Client Compression: none

[14:34:21] Authentication request. Method: "none"

[14:34:21] Server supported authentications: publickey,gssapi-with-mic,password

[14:34:21] Authentication request. Method: "password"

[14:34:21] User authentication successful.

[14:34:22] SSH session established.

[14:34:22] Connected to 67.228.5.228.

[14:34:22] SFTP protocol version 3

[14:34:22] Detected Server Software: OpenSSH

[14:34:22] Resolving path "/home/showip/public_html".

[14:34:22] Path successfully resolved.

[14:34:23] Reading directory "/home/showip/public_html".

[14:34:23] 2567 bytes transferred. (8,41 KB/s) (298 ms)

[14:34:23] Directory listing complete.

[14:34:33] Getting attributes of "/home/showip/public_html/test/info.php".

[14:34:33] 2 No such file

[14:34:34] The operation has been added to the Transfer Queue. Check the Transfer Queue for the status.

[14:34:35] Getting attributes of "/home/showip/public_html/test/info.php".

[14:34:35] Attributes successfully obtained.

mb

2008-06-29 15:40:49

Hello ..

The web server throws an internal error. This is most likely because php is not correctly configured on the server or there is some problem in your php code. If you have access to the apache/php error logs inspect them otherwise contact your web hosting provider for assistance. The problem is not related to SmartFTP or the FTP transfer.

Regards,
Mat

Mavol

2008-07-01 12:51:45

Turns out it was a problem with the configuration of Phpsuexec.

Too bad the FTP over SSL Explicit doesn't work but no matter now.

Thanks for the help.