Smart FTP crashes on download


I recently purchased V3 of SmartFTP and I seem to have a problem that the previous version didn't have: whenever I select a remote file and press the download button in the middle, SmartFTP crashes. It doesn't send the file to the queue, it doesn't do anything other than crash with the Windows prompt of 'SmartFTP has encounted an error and must restart'. It then provides me with a useless help and support pop-up about the problem being with Windows Vista and I should see the KB article KB938979 to fix this problem.

Now, apart from the fact that when I try to download and install that patch from Microsoft it tells me it doesn't relate to my system since I already have it, this problem didn't exist with SmartFTP v2. I can download the file if I right click on the file choose download from the menu, but the middle button crashes. I can also upload files without a hitch so far.

Hope you can help.

System Info

+- System -----------------------------
Microsoft Windows Vista Ultimate Edition
(Build 6000)

CPU Speed : 2161 MHz
Total Memory : 2047 MB
Free Memory : 1081 MB

+- SmartFTP ---------------------------
Version : 3.0.1015.1
Time Stamp : 2008-04-29 21:17:09
Platform : x86
Id : 400021864
Days in use : 346

+- Application DLL --------------------
sfFTPLib.dll :
sfFavorites.dll :
sfFavoritesShellExtension.dll :
sfTransferQueue.dll :
sfFTPShellExtension.dll :

+- Language ---------------------------
SmartFTP.exe : 3.0.1015.1

+- Internet Explorer ------------------
Version : 7.0.6000.16643

+- Winsock ----------------------------
Winsock : 2.2

I managed to create a dump file of the crash with the Debugging tool for Windows. I have created a zip file, but it is quite large... well over 100mb. I don't particularly want to upload it, particularly with my ftp program not working correctly. There's 3 .dmp files over 100mb each, an ADPlus_report.txt and process_list.txt files, and a single .log file. The three dmp file are named:


If there is one that is of particular interest I can upload a zip of that file.

Oh, and I'll also put my 2cents in with disliking of the queue option... I had it turned off in the previous as I didn't, and still don't, have a need for a queue... but I'm sure I will get used to it. It's just a pain the arse that I have to update my 30+ favourites in order to "setup a dual transfer environment"... and even then I'm not sure it is going to work because I am constantly working with 5 to 10 websites at a time and uploading seperately to each of them. (Or am I missing something about the dual transfer situation?). Anyway we can have a global setting that one can set that would create the dual transfer scenario automatically, with the favourites being used to overwiite this setting?

Also, is there anyway to get the old style warning messages back? I personally hate the Vista 'Copy, Copy and replace' warnings I get now with SmartFTP v3 when I'm going to overwrite a file. The old style was so much more simpler.


I have uploaded that file to the following url:

Click HERE


Thank you.

What is the current location (what folder are you downloading the files to) in the Local Browser?

Does it happen with all destinations or just one particular folder?


For a moment there I thought it was working, but now the problem remains. I tried to replicate what I did to see if I could get it working again, but to no avail. It was working after it had crashed. When I tried to start it again, I had lost ALL my favourites. In order to get them back, I copied the files from favourites.old folder in my AppData\Roaming\SmartFTP\Client 2.0 to the favourites folder in the same directory. Restarted SmartFTP, and that was when it was working. Not sure if that helps at all.

As for your question, it happens for all folders, regardless of location/partition/drive.

Also, it works if I choose Download To -> and choose the current folder in the Local Browser. For some reason it only occurs when I use the download button in the middle bar.

Please try it again with the latest version

BTW: No favorites will get lost because of a crash in SmartFTP. You can find them in the menu: Favorites->Edit Favorites. The old favorites.old is not used in the vesrion 3.0.


Nope, same problem. Version 3.0.1015.2...

As for the favourites, I couldn't edit them because there was nothing there to edit... the folder was empty and the Edit Favourites didn't work. If it happens again I'll let you know.

Can you create another crash dump with the new version?

Do you have anything "special" installed on your computer? Antivirus or other tools that hack into the system?

Thank you.


Also, and this is just a bit of annoyance, when I install SmartFTP, it asks me to shut down Windows Explorer (not Internet Explorer)... so I tell it to do it automatically, and it closes Vista down (as in the explorer.exe... it doesn't shut down my computer). Luckly Vista reboots explorer.exe when the SmartFTP program finishes installing. Not sure if it's related to anything, but yeah, just an annoyance and concern.

Can you create another crash dump with the new version?

Do you have anything "special" installed on your computer? Antivirus or other tools that hack into the system?

Thank you.


I'll go about creating another dump as soon as I can.

As for anything 'special'. Hard to say. My virus program is Trend PC-cillin 2007, I have Tortoise SVN installed, WAMP server... that's the only things I can see being special. And these were all installed when I was using SmartFTP v2.x. But why would anything stop the middle download button from working but allow the right click -> download/download to option to work. The only differences I can see between those actions is that the middle button has to reference the Local Browser inoder to get the path to download to. The right click options either have the path assigned (via history) or user defined in a browser dialogue.

New dump file:

Click Here


The middle copy button emulates copy&paste from one to another window. So this should crash as well.

Please export the following registry keys:


Then zip all the .reg files and upload the .zip to


Reg keys can be found at the following:

Click Here

Just so you know, I couldn't copy the following Reg keys because they didn't exist:


The rest were there.

Also, going by what you said about the copy option, I tried a couple of more things. The middle button works for any file and for any directory so long as I do a Copy (right click) from the remote to local browser first. Once I do this, the middle download button works fine. The thing is that I have to choose Paste twice before the file will copy. However this does not apply if I first use the Download/Download To options. If I hit the middle download button after that it just crashes as per usual.

I am about to download the new SVN, so will let you know how that goes.

I installed the latest TortoiseSVN, but it didn't do anything either. Same problem.


I noticed you have a couple of drag&drop copy handlers installed. One of them is tosbtext which is a shell extension for Toshiba's Bluetooth driver. Others have experience problems with this as well:

My recommendation is to proceed as following:
1. Keep a backup of the exported keys (or export them again to have the latest data)
2. Delete the following registry key entries:


3. Restart SmartFTP
4. If it doesn't work we delete the next drag handler
5. Delete

6. Restart SmartFTP
7. If it doesn't work delete all the DragDropHandlers but "SmartFTP Drop Handler"

You can always restore the registry later by importing the .reg files saved in step 1.


Removing the Toshiba Bluetooth keys did the trick. Thank you very much for that!

Do you happen to know how that might effect the Bluetooth driver? Not that I use bluetooth very often, but just in case I need to make note of anything...


Yes it's a bug in the Bluetooth driver.