About hosts

intro

2008-04-17 16:17:08

I am wondering why when, for example, I try to open ftp (or sftp) connection on host (eg.) "subhost.some_host.com" and then I try to connect with "some_host.com" then connection all time want to be on first of above hosts? And probably I see vice versa.

Now I can not connect with eg. some_host.com becouse it still tryes connect to subhost.some_host.com ?

mb

2008-04-17 19:08:07

Sorry I don't understand what you mean.

intro

2008-04-17 19:33:54

Sorry I don't understand what you mean.
So I will try step by step

For example lets take "some_host" as some host name (exactly it was one of my host names).

About half day ago I had to quickly connect with this some host, for example lets take it as "office.some_host.com". So connection estabilished and other things ... but ...

Few hours later I had to connect with "some_host.com" (without subdomain "office") and I could not connect with that host becouse SmartFTP all time want to connect with "office.some_host.com".

This case is related to quickly connect with ftp, port 21 (via Adress, Login, Password) - without use the favorites.

If I then used Favorites, there were no probs, but some host do not need to be added to favorites.

So I could not quickly connect with some_host.com if I earlier connected with office.some_host.com. I checked it also without cache Enabled etc. And nothing. Some time ago I had similar problem, but I forgot about it becouse some time I have not been using SmartFTP, but since there is SFTP, that is other world

I hope now it is clear, if You want to have more details, please ask about anything

mb

2008-04-17 19:50:05

Hello ..

I don't really have a explanation what happened in your case but I recommend you to use the quick connect dialog (Ctrl+N) to connect to a new server. This will avoid confusion in the future.
If you enter the information directly into the address bar SmartFTP tries to find an existing favorite with matching information. If no favorite exists it will create one on the fly and add it to the Quick Connect favorites folder. As you can see you will always use a favorite.

Regards,
Mat

intro

2008-04-17 20:22:14

Hmm, Mat ...

It was very simply ... firstly I connect with office.some_host.com, and next I was trying to connect with "some_host.com" (without subdomain). But SmartFTP was in second step still tryed to connect with office.some_host.com (as via firstly connection).

This case was by using toolbar with adress, login and password (I did not used Ctrl+N and in this way, yes, it works ok).