Reaches 99% then retrys

jonnyross99

2008-02-28 14:32:25

hiya,

i have a particular problem with uploads.google.com i dont see this behaviour with any other ftp site but maybe someone reading my log can help identify the problem....

log:-
[14:25:20] Resolving host name "uploads.google.com"
[14:25:20] Connecting to 72.14.200.3 Port: 21
[14:25:20] Connected to uploads.google.com.
[14:25:23] 220 FTP server ready.
[14:25:23] USER jonnyross
[14:25:23] 331 Password required for jonnyross.
[14:25:23] PASS (hidden)
[14:25:24] 230 User jonnyross logged in. Access restrictions apply.
[14:25:24] SYST
[14:25:24] 215 UNIX Type: L8
[14:25:24] Detected Server Type: UNIX
[14:25:24] FEAT
[14:25:24] 500 'FEAT': command not understood.
[14:25:24] TYPE I
[14:25:24] 200 Type set to I.
[14:25:24] REST 0
[14:25:25] 350 Restarting at 0. Send STORE or RETRIEVE to initiate transfer.
[14:25:25] PWD
[14:25:25] 257 "/" is current directory.
[14:25:25] Remote file exist check: "googlebase.txt".
[14:25:25] SIZE googlebase.txt
[14:25:25] 550 googlebase.txt: not a plain file.
[14:25:25] File size check (SIZE) failed. File not found or permission denied.
[14:25:25] PASV
[14:25:25] 227 Entering Passive Mode (72,14,200,3,69,12)
[14:25:25] Opening data connection to 72.14.200.3 Port: 17676
[14:25:25] STOR googlebase.txt
[14:25:25] 150 Opening BINARY mode data connection for googlebase.txt.
[14:26:49] 3098964 bytes transferred. (36.2 KB/s) (00:01:23)
[14:27:49] Timeout (60s).
[14:27:49] Active Help: https://www.smartftp.com/support/kb/74
[14:27:49] Client closed the connection.
[14:27:49] Resolving host name "uploads.google.com"
[14:27:49] Connecting to 72.14.200.3 Port: 21
[14:27:49] Connected to uploads.google.com.
[14:27:52] 220 FTP server ready.
[14:27:52] USER jonnyross
[14:27:52] 331 Password required for jonnyross.
[14:27:52] PASS (hidden)
[14:27:53] 230 User jonnyross logged in. Access restrictions apply.
[14:27:53] SYST
[14:27:53] 215 UNIX Type: L8
[14:27:53] Detected Server Type: UNIX
[14:27:53] FEAT
[14:27:53] 500 'FEAT': command not understood.
[14:27:53] TYPE I
[14:27:53] 200 Type set to I.
[14:27:53] REST 0
[14:27:53] 350 Restarting at 0. Send STORE or RETRIEVE to initiate transfer.
[14:27:53] PWD
[14:27:54] 257 "/" is current directory.
[14:27:54] Remote file exist check: "googlebase.txt".
[14:27:54] SIZE googlebase.txt
[14:27:54] 550 googlebase.txt: not a plain file.
[14:27:54] File size check (SIZE) failed. File not found or permission denied.
[14:27:54] PASV
[14:27:54] 227 Entering Passive Mode (72,14,200,3,69,59)
[14:27:54] Opening data connection to 72.14.200.3 Port: 17723
[14:27:54] STOR googlebase.txt
[14:27:54] 150 Opening BINARY mode data connection for googlebase.txt.


looking forward for someone to shed some light!

regards
Jonny

mb

2008-02-28 21:03:14

This is a typical problem when the NAT router disconnects the control connection during a data transfer. There is one workaround: Go to the Favorite settings. Then FTP->Transfer dialog and enable the "Send NOOP during trabsfer" option.

Since the Google's FTP server doesn't let you use the SIZE command you have another problem. SmartFTP will never be able to verify if the transfer has been successful or not and it cannot resume broken transfers due to the server limitations. To ignore the transfer verification check you need to install the latest version of SmartFTP from: https://www.smartftp.com/download
Then in the Favorite settings in the Transfer dialog enable the "Ignore Error" option. Now the Transfer Queue will not verify your transfers.

My recommendation is to contact Google about this problem and ask them to provide a more usable FTP server implementation.

Regards,
Mat

jonnyross99

2008-02-29 08:51:46

thanks for this, i have posted the question in googles help group...see
http://groups.google.com/group/base-hel ... 7d2bc8b7b2

in the meantime does setting "Send NOOP
during transfer" cause me any problems with other ftp uploads i make?

regards
Jonny

mb

2008-02-29 08:57:18

Hello ..

No it shouldn't. But you should only enable it for the google server.

Regards,
Mat