Objects not writing to screen

hunsford

2008-02-27 15:50:06

v.2.5.1008
Windows XP with Office 2003

Issue
When I reactivate the SmartFTP window after it has been minimized, it takes time for certain objects to "write" to the screen. I have to sit there and wait for the object(s) to write to the screen before I can do anything. This also happens if I activate another window in front of SmartFTP. It does not happen if I activate another window on my other monitor and then return to SmartFTP. It's only an issue if parts of the SmartFTP window have to be written to my screen.

This first occurred several weeks ago with the Transfer Queue, Connections, and Speed windows. When I activated the SmartFTP window, I'd have to sit there and wait for these objects to write to the screen. In the meantime, the previous window was visible where the Transfer Queue, Connections, and/or Speed window was supposed to be. It would usually take 45 to 90 seconds for the object to write to the screen before I could continue with my task.

What I Tried
I thought it might have something to do with the skin, so in Settings, I changed the interface to Native Windows instead of Office 2003, but this didn't help.

Initial Workaround
I finally worked around the issue by turning off the Transfer Queue, Connections, and Speed windows. I miss the Transfer Queue, but I'd been getting an instant response, so it was worth the trade off.

Problem Has Resurfaced
The problem has resurfaced, but now it's with almost every remaining object on the screen -- Folders panes, menu bar, address bar, remote browser, log (see image; you can see how my desktop continues to display where these objects should be). What could be causing the delay in writing objects to the screen?

Image