Unable to Overwrite Files During FTP Upload Transfer

scso1502

2008-02-19 23:07:09

Does anyone know why I can't overwrite existing files on servers I upload to using SmartFTP? I'm running version 2.5.1008. It used to work fine, but sometime within the past month is stopped. Now I have to rename the files before sending them. This even happens if I delete the file on the remote host before uploading a fresh copy. It's like the file is cached somewhere. Any help would be greatly appreciated before I lose my mind. This is such a pain.

Thanks!

mb

2008-02-19 23:22:57

Hello Mike ..

Please post the log of your FTP session.

BTW: You can use the Premium forum as a licensed customer with a maintenance plan.

Regards,
Mat

scso1502

2008-02-21 00:36:31

Thanks for the reply Matt....

I realize I have a registered copy, but wanted to avoid bothering the folks in support if someone had the answer here. I may end up doing that if I can't resolve it this way.


Here's the log you requested. I've determined the only time this error occurs is when trying to upload and overwrite a file that has been changed and is now different than the one on the host.

LOG OF FAILURE AFTER FILE IS CHANGED AND UPLOAD IS ATTEMPTED:

[16:30:48] Remote file exist check: "server.cfg".
[16:30:48] SIZE server.cfg
[16:30:48] 213 8789
[16:30:48] MDTM server.cfg
[16:30:48] 213 20080221002845
[16:30:48] No rule matched. Default Action="Ask".
[16:30:52] PASV
[16:30:52] 227 Entering Passive Mode (216,83,33,50,9,76).
[16:30:52] Opening data connection to 216.83.33.50 Port: 2380
[16:30:52] STOR server.cfg
[16:30:52] 125 Data connection already open; Transfer starting.
[16:30:52] 8790 bytes transferred. (138 KB/s) (62 ms)
[16:30:52] 226 Transfer complete.
[16:30:52] SIZE server.cfg
[16:30:52] 213 8789
[16:30:52] File size mismatch.
[16:30:52] TYPE A
[16:30:52] 200 Type set to A.
[16:30:52] PASV
[16:30:52] 227 Entering Passive Mode (216,83,33,50,9,77).
[16:30:52] Opening data connection to 216.83.33.50 Port: 2381
[16:30:52] LIST -aL
[16:30:52] 125 Data connection already open; Transfer starting.
[16:30:52] 917 bytes transferred. (59.7 KB/s) (15 ms)
[16:30:53] 226 Transfer complete.
[16:30:53] Transfer failed. Use the Transfer Queue for automatic retries.

BELOW IS THE LOG OF A SUCCESSFUL TRANFER WHEN THE FILE HASN'T BE CHANGED PRIOR TO ATTEMPTING THE UPLOAD:

[16:34:37] Remote file exist check: "server.cfg".
[16:34:37] TYPE I
[16:34:37] 200 Type set to I.
[16:34:37] SIZE server.cfg
[16:34:37] 213 8790
[16:34:37] MDTM server.cfg
[16:34:37] 213 20080221002948
[16:34:37] No rule matched. Default Action="Ask".
[16:34:38] PASV
[16:34:38] 227 Entering Passive Mode (216,83,33,50,9,87).
[16:34:38] Opening data connection to 216.83.33.50 Port: 2391
[16:34:38] STOR server.cfg
[16:34:39] 125 Data connection already open; Transfer starting.
[16:34:39] 8790 bytes transferred. (92.3 KB/s) (93 ms)
[16:34:39] 226 Transfer complete.
[16:34:39] MDTM 20080221002605 server.cfg
[16:34:39] 550 20080221002605 server.cfg: The system cannot find the file specified.
[16:34:39] MFMT 20080221002605 server.cfg
[16:34:39] 500 'MFMT 20080221002605 server.cfg': command not understood
[16:34:39] SITE UTIME server.cfg 20080221002605 20080221002605 20080221002605 UTC
[16:34:39] 500 'SITE UTIME server.cfg 20080221002605 20080221002605 20080221002605 UTC': command not understood
[16:34:39] SITE UTIME 20080221002605 server.cfg
[16:34:39] 500 'SITE UTIME 20080221002605 server.cfg': command not understood
[16:34:39] SIZE server.cfg
[16:34:39] 213 8790
[16:34:39] TYPE A
[16:34:39] 200 Type set to A.
[16:34:39] PASV
[16:34:39] 227 Entering Passive Mode (216,83,33,50,9,88).
[16:34:39] Opening data connection to 216.83.33.50 Port: 2392
[16:34:39] LIST -aL
[16:34:39] 125 Data connection already open; Transfer starting.
[16:34:39] 917 bytes transferred. (59.7 KB/s) (15 ms)
[16:34:39] 226 Transfer complete.
[16:34:39] Transfer successful.

THANKS!
Mike

scso1502

2008-03-10 17:17:08

I'm still waiting for a response on this.. Can someone please Help me?

Thanks!
Mike Vail

mb

2008-03-10 19:44:12

Hello Mike ..

From the log I can see that SmartFTP sent 8790 bytes but the server only received 8789 bytes.

16:30:52] 8790 bytes transferred. (138 KB/s) (62 ms)
[16:30:52] 226 Transfer complete.
[16:30:52] SIZE server.cfg
[16:30:52] 213 8789

It means SmartFTP should retry this transfer again until all bytes have been received from the server. To do this I recommend you to use the Transfer Queue. It automatically retries the transfer until its finnished. Please take a look at the transfer queue tutorials at:
https://www.smartftp.com/support/howto

Regards,
Mat

scso1502

2008-03-13 01:01:05

Thanks for the reply Matt. I'd like to throw this one other idea at you before I use the trasnfer que. This just doesn't make sense yet.

This problem only occurs when a file already exists on the destination and only if the file has been modified and is of a different size than the server copy. If I rename the file before transferring it, all works fine. I then have to delete the original file on the server and rename the one I copied to complete the copy process. I don't quite see how using the transfer queue would fix that.

This appears to only be occurring when I'm transferring to Windows 2003 servers via Port 22, not the usual port 21. I have confirmed the incoming settings on the Windows 2003 Servers are set to read and write, so I don't believe it's a permissions issue.

Do you have any other thoughts?

Mike

mb

2008-03-13 03:17:17

It looks like a server problem to me. The server returns the size of the previous file in the SIZE reply. This was a common problem with pureftpd and other servers as well.

I noticed that the maintenance (technical support + upgrades) of your license expired last year. Please renew it at:
https://www.smartftp.com/purchase/renew.php

Thank you.

Regards,
Mat

popup

2008-03-17 13:35:53

Hi all,

I experienced the same problem: file upload/download doesn't prompt in case of existing file...and overwrite randomly.

After a (smart) research on the internet, some users experienced the same problem, wondering about LOGS or "SIZE" ftp command and RFC rules, or upgrading FTP client.


BUT!! the SOLUTION is to clear history (tool/settings/history)-> clear.

thanks to the team to repeat this words, thus users like me doesn't spend a day couldn't working, and angrying.

scso1502

2008-03-17 14:39:17

I don't have a "Clear" command in the history settings, the thing I can change there is a check-box that says "Save history". If you meant "delete" I did do that. I don't even know what history is for, but I assume its a transaction summary for each connection. I don't understand how this would fix the problem. I unchecked the save box and deleted all the history by selecting and deleting the items, but it still has the same problem and still shows the connections when I come back to history. I assume it's just not saving the data related to the connections now, only listing them for reference.

Anyway. no go. I'm leaning toward a sever problem too, but I don't know why that would be. Interestingly, if I delete the file I want to copy from the server first, then do the copy, it works fine. It's just happening when there's an existing file of different size and the file-exist check shows they are different. I have no idea what I can do on the server end to fix this. There are only 2 settings I can control on the Windows 2003 server, "Read" and Write" access enabled or disabled.

TO THE SUPPORT FORUMS MODERATOR: I understand my support time has run out. I do not wish to renew it because I have never used it until now. Your product is just too good - LOL! Would you please move this post the general area and out of the paid support area? I want to follow your rules and I'm sorry I posted it here. I only did so after being told to by a SmartFTP admin who apparently was unaware my support contract had expired.

Thank you,
Mike Vail

popup

2008-03-17 17:27:23

I'm sorry it didn't work for U.

Actually, i'm not sure what i really made to my smartftp making it works again. Because i try many options:

I reinstall, backup settings, and try different settings in "tool->setting", concerning" file exists" option.(i delete all option, restore default...)

but nothing happens.

later,
i also try thoses options in "favorite/properties", where the option "file exists" refers to "use global setting"" or "use favorite setting".

Change it and valid, quit SMTP and reload. Re-chan,ge it to default....

but nothing happens.

At the last, i delete history, quit SMTP and reload...and then It works again...
what is the right to be done?? I'm not sure, but spending time.

scso1502

2008-03-17 17:51:21

Ok, well.. thanks for trying... Have a good day!

Mike