Cannot Connect

vectorw8

2008-01-31 16:49:26

I recently updated my license for SmartFTP and since I have not been able to connect. I also have changed ISP's and that may be an issue. I have tried to troubleshoot by pinging the ISP, router, and host with success. Appears that all IP's are valid. I also increased the timeout of FTP. Here are the messages I am receiving:

[10:39:46] Detected Server Software: PureFTPd
[10:39:46] PWD
[10:39:46] 257 "/" is your current location
[10:39:47] TYPE A
[10:39:47] 200 TYPE is now ASCII
[10:39:47] PROT P
[10:39:47] 534 Fallback to [C]
[10:39:47] PROT C
[10:39:47] 200 OK
[10:39:47] PORT 192,168,1,3,6,0
[10:39:47] 500 I won't open a connection to 192.168.1.3 (only to 24.159.241.127)

534 Fallback to [C]
[10:37:25] PROT C
[10:37:25] 200 OK
[10:37:25] PASV
[10:37:25] 227 Entering Passive Mode (208,76,80,74,46,131)
[10:37:25] Opening data connection to 208.76.80.74 Port: 11907
[10:37:25] MLSD
[10:37:46] A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
[10:39:46] Timeout (120s).

Thanks,
Dennis

mb

2008-01-31 20:23:20

Hello ..

Try to use the "Normal FTP" protocol instead of "FTP over SSL". To change it go to the General dialog in the favorite settings.

Regards,
Mat

vectorw8

2008-02-01 01:57:39

Thanks,

That appears to work. However, is there any consequence to not using SSL? I have always used it in the past with no issues. Not sure why I cannot use it now.

Dennis

mb

2008-02-01 03:00:40

If you use FTPS (FTP over SSL/TLS) the protocol information (e.g. username/password) are transferred through a secure channel. If you use FTP the data is sent in clear text.
The problem in your case is that when using a secure channel (FTPS) your router is not able to read the commands in your session and therefore is not able to automatically setup the correct entries (for port forwarding etc) in its NAT table. You can workaround the problem by changing the data transfer settings in SmartFTP but this might not work either. Using the FTP protocol is the "easier" but less secure solution.
Regards,
Mat