connection occurs on second try

plbye

2008-01-21 15:18:23

I usually connect via FTP only to one site, the website that I maintain. Recently with version 1.5 and now still with 2.5 I find that the first connection fails, the system waits 30 seconds, and then the connection is made and operates normally. Here is a sample logfile:

[23:52:47] SmartFTP v2.5.1008.27
[23:52:47] Resolving host name "016FA25.netsolhost.com"
[23:52:47] Connecting to 205.178.145.65 Port: 21
[23:52:47] Connected to 016FA25.netsolhost.com.
[23:52:47] An established connection was aborted by the software in your host machine.
[23:52:47] Cannot login waiting to retry (30s)...
[23:52:47] Server closed connection
[23:53:17] Continue to login attempt 2...
[23:53:17] Resolving host name "016FA25.netsolhost.com"
[23:53:17] Connecting to 205.178.145.65 Port: 21
[23:53:17] Connected to 016FA25.netsolhost.com.
[23:53:17] 220 (vsFTPd 2.0.5)
[23:53:17] USER ntsl591589%016fa25
[23:53:17] 331 Please specify the password.
[23:53:17] PASS (hidden)
[23:53:17] 230 Login successful.
[23:53:17] SYST
[23:53:17] 215 UNIX Type: L8
[23:53:17] Detected Server Type: UNIX
[23:53:17] FEAT
[23:53:18] 211-Features:
[23:53:18] EPRT
[23:53:18] EPSV
[23:53:18] MDTM
[23:53:18] PASV
[23:53:18] REST STREAM
[23:53:18] SIZE
[23:53:18] TVFS
[23:53:18] 211 End
[23:53:18] PWD
[23:53:18] 257 "/"
[23:53:18] CWD /htdocs
[23:53:18] 250 Directory successfully changed.
[23:53:18] PWD
[23:53:18] 257 "/htdocs"
[23:53:18] TYPE A
[23:53:18] 200 Switching to ASCII mode.
[23:53:18] PORT 192,168,2,3,9,58
[23:53:18] 200 PORT command successful. Consider using PASV.
[23:53:18] LIST -aL
[23:53:18] 150 Here comes the directory listing.
[23:53:18] 8420 bytes transferred. (40.5 KB/s) (203 ms)
[23:53:18] 226 Directory send OK.
[23:53:49] NOOP
[23:53:49] 200 NOOP ok.

Note - I always click disconnect at the end of a session to terminate the connection prior to closing SmartFTP.

Any ideas how to stop this behavior and get the connection made on the first try?

Thanks.

Pete

mb

2008-01-21 18:04:29

Hello ..

You can increase the timeout from 30 seconds to 60 seconds in the favorite settings. However I believe the problem doesn't originate from SmartFTP. It might be your software firewall or the server itself.

Regards,
Mat

plbye

2008-01-21 18:15:41

Hi Mat,

Thanks. The system is behind a router (Belkin) with a built-in hardware NAT firewall. No software firewall runs on the PC. This configuration is unchanged from when it used to connect properly on the first try.

I should have mentioned that the system runs Windows XP Pro SP2.

I will try increasing the timeout as you suggest.

The servers are Network Solutions. Have other users experienced this?

Pete

mb

2008-01-21 19:27:48

To locate the origin of the problem try the following:

1. Connect to ftp://ftp.smartftp.com. If this works then the problem is very likely on the server side.
2. Try another FTP client to connect to the server in question. E.g. use the command line ftp client (ftp.exe): ftp.exe 016FA25.netsolhost.com

These tests give you a good idea where the problem might be but are not necessary a proof for it. E.g. sometimes you can connect to some servers without any problems and others don't work and the actual problem is not on the server side.

Regards,
Mat

plbye

2008-02-13 00:22:41

Hi Mat,

Thanks for your follow-up. I tried your suggestions. SmartFTP connects to the SmartFTP ftp site smoothly. The command line as well as the ftp function built into V-com's fix-it utilities has a response similar to what I see from SmartFTP. Here is the sequence from the command line showing that the first time I did the command line the connection failed and the second time it worked:


C:\Documents and Settings\Pete>ftp.exe 016FA25.netsolhost.com
Connected to 016FA25.netsolhost.com.
Connection closed by remote host.

C:\Documents and Settings\Pete>ftp.exe 016FA25.netsolhost.com
Connected to 016FA25.netsolhost.com.
220 (vsFTPd 2.0.5)
User (016FA25.netsolhost.com:(none)): ?
331 Please specify the password.
Password:


To your point, this certainly seems to point towards Network Solutions. Their technical support tried logging into the same ftp server, though, and connected with no difficulty. They claim based on this that the problem is not with their server. I welcome other thoughts and suggestions. I will also try Network Solutions technical support again.

mb

2008-02-13 00:25:53

I have exactly the same problem here. So it definitely looks like a server problem:

C:\Users\mb>ftp.exe 016FA25.netsolhost.com
Connected to 016FA25.netsolhost.com.
Connection closed by remote host.

C:\Users\mb>ftp.exe 016FA25.netsolhost.com
Connected to 016FA25.netsolhost.com.
220 (vsFTPd 2.0.5)
User (016FA25.netsolhost.com:(none)):



Regards,
Mat

plbye

2008-02-13 01:10:39

Many thanks for this added input; it is more "ammunition" that I can present to Network Solutions

Vorenus

2009-02-12 13:56:38

Reviving a one-year-old thread, but this exact problem still occurs with the very latest beta of SmartFTP, including versions prior to it (stable or beta).

I'm not yet a registered user but I would definitely register if it supported my NetworkSolution accounts properly.

Please can something be done about it? All the other clients (FileZilla, etc) I have tried work fine with NetworkSolutions.

Thanks.

mb

2009-02-12 14:03:10

Vorenus: What problem are you referring to exactly?

Vorenus

2009-02-12 14:41:35

Vorenus: What problem are you referring to exactly?

This error that the OP has been mentioning:
"An established connection was aborted by the software in your host machine."

Here is the full error log.

[15:31:14] SmartFTP v3.0.1026.2
[15:31:14] Resolving host name "xxxxxx.netsolhost.com"
[15:31:15] Connecting to xxx.xxx.xxx.xx Port: 21
[15:31:15] Connected to xxxxxx.netsolhost.com.
[15:31:15] An established connection was aborted by the software in your host machine.
[15:31:15] Connect failed. Waiting to retry (30s)...
[15:31:15] Server closed connection

I then have to exit SmartFTP and try it.
Most of the time, it works the second try, sometimes a third one is required.
Trying again from the same SmartFTP session (without exiting first) doesn't work. A new tab just opens but nothing happens (only "[15:35:11] SmartFTP v3.0.1026.2) is shown in the log window.

SmartFTP has no problems connecting to my old provider or other FTP servers, but, other FTP clients have no problem connecting to NetworkSolutions.

That's annoying because SmartFTP has a great feature I'm missing from any other client (Ctrl+C / Ctrl+V from/to Windows Explorer) and is great otherwise. It is the only thing prevening me to register at the moment: since I'm mostly working with NetworkSolutions servers, this issue is quite annoying.

If you need more informations, please do not hesitate to let me know.

Thanks,

EDIT: I forgot to mention that I have no software firewalls installed on my machine (even the Windows XP one is disabled) and that I have standard NAT routers both at home and at the office. The problems happens no matter where I am and the routers are of different make and models.

plbye

2009-02-12 14:58:25

I can tell you how it was resolved last year. Perhaps this is helpful.

First, Network Solutions finally admitted it was a problem in their servers. I forget the details. They did fix it although the problem reappears periodically. I had to send them a full log and might have gone through a tech support escalation.

I figured out a work-around that makes this manageable when the problem does surface. In SmartFTP, set the default connection, or the specific one with which you're having difficulty, to a 1 second retry interval. That way it immediately retries and connects. It makes the problem almost painless.

To make the change, in SmartFTP go to Favorites -> Tools -> Edit default connection. In the connection, change retry time to 1 second. Or right click a specific favorite and edit its properties.

Vorenus

2009-02-19 15:43:14

Well, this workaround does help a bit indeed and I thank you for this, but unfortunately it isn't the only problem I have between SmartFTP and NetworkSolutions.

For example, sometimes, when I connect, the directories/files list on the FTP server isn't coming up.
Here is what can be seen in the log.

[16:38:07] LIST -aL
[16:38:07] 0 bytes transferred. (0 bytes/s) (156 ms)
[16:39:07] 425 Failed to establish connection.

Close SmartFTP and restarting it works fine most of the time.
As I said, I have no problems with other FTP clients such as FileZilla.

Thanks.

mb

2009-02-19 20:35:40

It's very unlikely a problem with SmartFTP. But if you can show otherwise we are more than happy to fix it.

Vorenus

2009-02-20 08:40:57

It's very unlikely a problem with SmartFTP. But if you can show otherwise we are more than happy to fix it.

It doesn't happen with any other client I tried. It works fine all the time with these on the exact same computer...
I'm not sure how I could show it differently than that.
These problems happen even on computers with a pristine and freshly installed Windows XP.
I tried CuteFTP Pro, FileZilla, and FTP Voyager and never a single problem with them at all.
The thing is that I don't want to use them since they all lack the powerful drag&drop copy/paste implementation that SmartFTP has.

If you're interested I can probably open you an account on an empty directory on my space on the NetworkSolution server so you can try to see what happens?

On another matter, I also noticed that on the latest beta, SmartFTP doesn't go automatically on the remote directory specified in the connection profile: it just stays at the root instead of CWDing to the preset remote directory set in the profile. It worked fine in the one I downloaded a few days ago.

Thanks.

mb

2009-02-20 15:54:49

Hello ..

It would be great if you can give us a test account to reproduce the problem. Please send the login information to sales@smartftp.com

>Initial Path
Bug confirmed and will be fixed in the next version. Thank you for reporting.

Thank you
Regards,
Mat

mb

2009-02-22 01:34:18

>Initial Path
Bug fixed in the latest version:
https://www.smartftp.com/download

Regards,
Mat