Passing parameters to a scheduled smartftp

NewBalance

2007-12-10 05:48:22

Hi,
I can schedule smartftp in windows scheduler (as per previous advice), but it doesn't do anything because it has no instructions. What do I do or how do I pass the xml file too the scheduled app?

I have tried having smartftp start in the folder with the xml file in it, but that didn't work.

Ian M

mb

2007-12-10 10:12:00

Hello ..

It processes the default transfer queue file. You cannot specify the Transfer Queue file on the command line.

Regards,
Mat

NewBalance

2007-12-11 06:36:10

Mat,
assumption is it looks in the person who is logged on favourites directory, regardless as to which user the scheduled smartftp is using to logon with.

Ian M

mb

2007-12-11 21:43:05

Hello ...

SmartFTP reads the registry from the user that it's run as. The path to the favorites as well as the path to the transfer queue file is stored in the registry. Therefore SmartFTP loads the transfer queue and the favorites from the user SmartFTP is run as.

Regards,
Mat

NewBalance

2007-12-11 23:04:14

Hi Mat,
now I know why my Brisbane installation works and my Sydney one doesn't.

Thank you
Ian M

NewBalance

2007-12-14 01:41:52

Hi Mat,
the scheduled application doesn't do anything. It re-schedules itself, but doesn't actually shift any data or do any checks to see if there are any changes.

Ian M

mb

2007-12-14 02:35:23

Run the application under the same user account as the user you use for the scheduled task. Set the Transfer Queue to auto start (menu: Tools->Settings->Queue). Fill the transfer queue with some items. Save it. Close the Application. Configure a scheduled task.

Enable logging (Settings->General->Advanced) and then check the logs.

Regards,
Mat

NewBalance

2007-12-17 05:46:34

Hi Mat,
did all that.

Smartftp start automatically when scheduled but doesn't actually do any transfers. If I start the transfers then quite smartftp, when it starts at thernext scheduled time it continues where it left off. I have it configured to start automatically.

I am logged on as administrator, that is the account that smartftp will be using to run under as a scheduled task.

Ian M

mb

2007-12-17 06:00:33

Try to use a different user account.

You can also enabled extended logging by import the "Enable Log.reg" from the following zip file:
https://www.smartftp.com/Products/SmartF ... gLevel.zip

Regards,
Mat