SmartFTP Freezes On Startup

I paid for SmartFTP yesterday, and have used it perhaps 10 to 20 times since then. Mostly it has worked fine, only the last time I used it, it froze on startup (the interface partially displayed, and then moving the mouse over the interface showed an egg timer) and now it does that every time. Restarting the computer seems to be a solution, but I will not restart the whole computer every time I want to use FTP software I've paid for.

Please let me know what I can do to get this software working again. I don't feel like I have gotten the best value for my money...

1. Install the latest version from:
2. If this doesn't help delete the registyr key at: HKEY_CURRENT_USER\Software\SmartFTP. To do this open regedit.exe and to go the HKEY_CURRENT_USER\Software\SmartFTP branch and delete it.


I don't know if this helps, but I tried it just now and it was working again... I didn't restart; I just left the computer for a few hours, then ran the application again. So when it stops working, it freezes repeatedly, no matter how many times you shut it down and start it up again... But if the computer is left with SmartFTP not running, for several hours, it seems to be able to start normally again... Is there possibly any kind of lock file or something which could get jammed, and cause the app to freeze on startup?


Please let us know when you have a reproducible case. We need to be able to reproduce it on our test system to find the problem.
Thank you.


I am having much the same problem, only now it's worse, because the program will not open at all, but only gives me a popup saying to buy or upgrade. I went to the web site, but was informed that I have the current version, and my license does not expire until July 2008.

I have also had the same trouble with the system crashing and also needing to fill in all the ftp info every time the program opens, it will not save my IP addresses, nor my personal registration info.

When I tried to follow your advice to delete the registration key, my computer search function could find no such file names. Nothing!

~Marcia Cash, Traveler in Thyme

Hello Marcia ..

You forgot to activate SmartFTP with your license key. I have sent you instructions on how to activate it by email.