Whild Dragging and dropping files from Remote to Local I get a folder named SFTPDROP. I have uninstalled and re-installed Smart FTP. I even restarted my computer and I get the same problem. I am running Windows XP Media Center.

I have followed those instructions and even manually registered the SmartHook.dll and rebooted and the same issue reared it's ugly head.

When you manually registered the dll, did you have administrator privileges?


Yes, my account is included in the Administrator group.

Do you have any other suggestions? I purchased this program and love it other than this.

What operating system are you using? Please post your system information from the menu: Help -> About dialog.

Did you try to install SmartFTP under a different user account? Can you reproduce the problem on another system?

Please add your license key id to your forum profile:
https://www.smartftp.com/support/kb/how- ... f2587.html


I'm having the same problem. I've been a paying customer for years now, and install the latest updates as they become available. Apparently this is a persistent bug. My system is running Windows Vista Business. I've perused SmartFTP forums and tried it all and reached no solution. Frustrated, I even tried SmartFTP beta 3, which crashes within seconds of connecting to an FTP server so I was unable to determine if the problem will be resolved in upcoming releases. I'm guessing that the problem will be fixed in 3.0, because I noticed SmartFTP is no longer using SmartHook.dll. This is the first time I've ever experienced any really annoying problem with SmartFTP in many years, but if you can delay responding to this issue for another 13 days or your prudent, yet zealous moderator removes my comments about it again; my Maintenance period will be expired.

1. Add your license key id to your forum profile to identify yourself as a customer
2. Personal attacks are not welcome here
3. If you believe there is a bug file a proper bug report
4. This is the last warning. You seem to continuously violating the forum rules.

Dearest mb, Please do accept my apologies for breaking forum rules. By continuous, I assume you mean my last two posts so I'll try to explain. After experiencing the SFTPDROP bug, I searched the forums. I found several posts about the issue and some were inconclusive. So, in the public forums I asked for support. I politely asked the public for help. With no response there, searched all forums again and still found not posts that resolved the problem. I tried all suggestions. I then thought to myself, this is not a public support issue, but instead a bug that the developers of SmartFTP might be interested in solving. Therefore, I posted the bug to the bug forum. You prudently deleted it. I surely meant you no offense by noting that it was both prudent and zealous to do so. There obviously is not a flood of incoming spam or even traffic to these forums, and the information about the bug is quite relevant to current customers. Finally, I did add my license key to my profile last night, prior to posting a request for support into the premium support forum.

You wield much power in these forums and your final warning is taken to heart. I'm merely a customer. I have tried to be both courteous and prudent myself. I have indeed tried to follow the rules of this forum. I hope that you will forgive me for the terrible, offensive mistake I have made in the previous two posts.

Thank you and I look forward to learning how to resolve the SFTPDROP problem.

Okay ;-)

I believe I have just moved (not deleted) your post from the Premium Support forum to the Public Support forum because you didn't put a license key id in your profile.

To your problem:
Can you please post the system information from the menu: Help->About "System Information" dialog in SmartFTP?

Thank you

+- System -----------------------------
Microsoft Windows Vista Business Edition
(Build 6000)

CPU Speed : 1729 MHz
Total Memory : 1013 MB
Free Memory : 543 MB

+- SmartFTP ---------------------------
Version : 2.5.1008.27
Time Stamp : 2007-12-15 05:00:40
Platform : x86

+- Application DLL --------------------
sfFTPLib.dll :
sfFavorites.dll :
sfFavoritesShellExtension.dll :
sfTransferQueue.dll :
SmartHook.dll :

+- Language ---------------------------
SmartFTP.exe : 2.5.1008.27

+- Internet Explorer ------------------
Version : 7.0.6000.16575

+- Winsock ----------------------------
Winsock : 2.2

Thank you.

Try to delete the SmartHook.dll in the "%ProgramFiles%\SmartFTP Client" folder. If it doesn't let you delete the file the dll is loaded.

Then install the latest version from:

Reboot the system after the installation. If it doesn't work follow follow these steps:
- Open a command line (cmd.exe). Run it with elevated privileges otherwise the registration will fail.
- Go to the SmartFTP program files folder: cd "%ProgramFiles%\SmartFTP Client"
- Then type "regsvr32.exe SmartHook.dll"
- Reboot the system


Thanks. That latest build,

+- SmartFTP ---------------------------
Version : 2.5.1008.37
Time Stamp : 2008-02-01 00:10:32
Platform : x86

resolves the SFTPDROP problem on Windows Vista Business. For others that experience this issue, the links found at https://www.smartftp.com/download/ currently point to build 2.5.1008.27, which does not resolve the problem. You must use the link mb provided above to get the latest 32bit version.