File Corruption when using Queue

jamroom

2007-05-20 16:44:53

I just recently upgrade to SmartFTP 2.5, and have noticed that I'm encountering frequent file corruption when I upload using the queue. I can upload without using the queue and see no issues. Would it be possible to get a copy of the very last SmartFTP 2.0.x so I can test here to see if it is my network or system that has changed?

Thank you!

- Brian

mb

2007-05-20 22:36:53

Hello ...

Please contact us by email. It's very unlikely that SmartFTP corrupts any transfers.

Regards,
-Mat

jamroom

2007-05-23 23:26:17

I've been looking at the logs, and am seeing this error a lot:

[16:22:46] 451 jamroom-calendar.inc.php: Append/Restart not permitted, try again

I get it for most every file I am trying to transfer - setting the transfer type to PASV/PORT does nothing. Like I mentioned before I never had any issues with 2.0, so never bothered investigating the logs for the queue transfers.

Did a "default" setting change in 2.5 that I should be aware of?

I only see this when I use the queue - if I turn off the queue I do not see this error.

Thanks!

- Brian

mb

2007-05-23 23:54:53

Hello Brian ..

Please post the complete log.

Thanks
-Mat

jamroom

2007-05-24 15:48:54

How do I view the log for a queue item that is no longer in the queue? Is the log stored somewhere?

Thanks!

- Brian

mb

2007-05-24 16:20:58

Hello ...
You can enable logging in the Settings -> Advanced dialog. Or alternatively you can uncheck the "Automatically remove finished items" in the Queue settings dialog.

Regards,
-Mat