Queue Timer Doesn't Work


I have had the same problem and I think I have it figured out.

I dragged the files to the temporary queue window, selected all of 'em and right clicked on them, chose schedule, chose a time a minute away, chose "enable recurrence" and chose every minute (so I could see it all work). Then I dragged 'em all to the destination window so they know where to go. They automatically then go sit in the Transfer Queue window.

In the Transfer Queue window, after monkeying with it for a while, I got it to work after I did a "save as" in the transfer queue (little floppy icon in the transfer queue window). Now it's happily connecting every minute, checking to see if the file changed and uploading it only if it has. It would be a nice addition to the documentation and the tutorials to have a lot more detail on how you set this up.

Near as I can tell, Smart FTP will not perform this schedule magic unless it is actually running. (Before you think that sounds stupid, I had been using AutoFTP and it had a little module it ran on startup to watch the clock and transfer the files without launching a visible application). To set it up so Auto FTP will always be launched before your scheduled transfer, go to Start/Programs/Accessories/System Tools/Scheduled tasks, click Add Scheduled Task and follow the wizard to set up SmartFTP to launch a minute or two before your scheduled transfer time. It also might be helpful in Smart FTP to then choose "On Queue Complete" (next to the timer button in the Transfer Queue) and choose "Quit Application". Voila! The whole kit and kaboodle should run unattended and unnoticed -even if your computer restarts after a Windows autoupdate!

...or at least we'll see later tonight. I've set a scheduled task and gone back and changed things to run daily (instead of every minute) and I'm crossing my fingers and trusting it will get done.

Hello UncleGeo ..

>Save As...
This shouldn't be necessary. SmartFTP automatically choose/creates a default file (%APPDATA%\SmartFTP\Client 2.0\Transfer Queue.xml) if the file is empty.

>Start Transfer Queue before Scheduled tasks are active
This is correct. It also means that the application needs to be started before anything moves. In a future version we are planning to implement a service which will always run in the background. And SmartFTP can be used to add files/folders to the Transfer Queue of this service. For now the "trick" with the Scheduled Tasks should work in most situations.

Thank you for your feedback ;-)



Thanks! It sounds like I'm on the right track, but last night, the task scheduler started the program, uploaded the files and then deleted them from the transfer queue! I can only guess that, when it starts again tonight, the files would not automatically be recalled and placed in the Transfer Queue to upload. So, I'm stumped again. I have clicked "add" and added the saved queue I saved yesterday back into the transfer queue and they still show the proper schedule -so maybe it will work tonight.

Any ideas what I may have neglected or done wrong?

Also there are two ways to do a scheduled upload- individually, by highlighting one, a few, or all files then right clicking and setting a schedule or by globally using the "Timer" icon, which I assume just uploads whatever happens to be in the Transfer queue at the time. Do I have this right? Is there any advantage to doing it one way rather than the other besides what I've just described? I.e., I used the individual way but highlighted all the files -would it work better if I used the global "Timer" control?

Good to hear you are working on a background widget to auto-upload. I'm surprised this is actually rare in FTP programs, as there have to be close to 14 zillion people like me who pay for hosting somewhere and update their site files from their small office computers.


Hello ..

If you want the items to stay in the transfer queue you have to enable recurrence in the queue items properties.

The global queue timer can be used in situations where you want to completely stop the queue for a certain time. e.g you only want to process items during the night.


Thanks, but I had/have recurrence enabled in the right-click/schedule (there does not seem to be a choice in right-click/properties.

Smart FTP starts, contacts the server, uploads and promptly erases the files in the queue. It also erases them when you close the program (they ain't there when you reopen it.)

I'll try again tonight and see what happens.

Well, no go last night either.

The problem is, that when you close the program it wipes the transfer queue. So, when you start it again (manually or with Windows task scheduler) there are no files in the Transfer Queue to upload.

I found a setting in Tools/Settings/Queue/Options/ and set it to "Remember last queue state" and it still forgets what I had in the transfer queue when I restart the app.

I'm stuck here. I bought this to do scheduled uploads so I'm bummed that nothing I'm trying seems to work. This should be easier and the documentation on this is non-existent, near as I can tell. The rest of the program is great, but, if it won't do this for me, it's useless. This is pretty simple; I change files every day, that then need to be uploaded every day, and, rather than manually upload them every day, I'd like to use a program that will just go into the local folder, pull them out and upload them to the server automatically every day. I cannot be the only small business website owner with this need.

Can this really be done? If so, what am I doing wrong? If I have to wait for the new update to add a separate module, how long will that take? If it's a while, I'll guess I'll just need to eat the cost of Smart FTP, chalk it up to experience, and move on.

Hello ...

You are saying when you close the application it "wipes out" the transfer queue. Please try the following:
1. Start SmartFTP
2. Stop Transfer Queue
3. Add some files to the Transfer Queue
4. Close SmartFTP
5. Start SmartFTP
Question: Do you see the files you have added in the transfer queue?



Thanks for the reply. No I did not see files.

Exactly in order I:

Experiment #1
  1. Started Smart FTP. -no files were present in the Temp or Transfer Queues.
  2. Clicked Stop in Transfer Queue (there were no files in it but I clicked Stop anyway)
  3. Dragged some files from the local window to the Transfer Queue (they always actually end up in the Temporary Queue when I drag them to the Transfer Queue.)
  4. Looked in the Temporary Queue -the files were there.
  5. Highlighted the files in the Temporary Que and dragged them to the Destination window. They were no longer visible in the Temporary Queue but were there in the Transfer Queue.
  6. Closed the Program
  7. Started SmartFTP- no files were in either the Transfer Queue or in the Temporary Queue.
Experiment #2
Identical steps to Experiment #1 except:
  1. I scheduled the files (by highlighting all the files, right clicking and choosing Schedule) with a one minute recurrence (I made sure the files were freshly saved first so they would have a different date than the server's copies)
  2. I dragged them to the Destination Window
  3. The files transferred and I could see the scheduled time for each changed to one minute in the future in the Transfer Queue.
  4. I resaved the original files (html files) from within their original program so they'd have new save dates.
  5. Smart FTP transferred them again the next minute as expected.
  6. This next time I did not resave the originals but the next minute SmartFTP did transfer the files again.
  7. I closed the program
  8. I reopened the program -no files were in either Temporary or Transfer Queues.
Experiment #3
Same steps as Experiment #2 Except:
  1. I saved the Transfer Queue as "Daily2" (it chose ".XML" as a file extension)
  2. I waited for four transfers to complete.
  3. Closed Program
  4. Opened again, no files in either Queue.
Experiment #4
  1. Opened Smart FTP
  2. "Add"ed "Daily2" to the Transfer Queue
  3. Watched for a few transfer cycles (on some of which I resaved the original html files again)
  4. Closed the program, reopened and no files were present.
FYI, for all Experiments On Cue Complete = Idle

I also did a search for the Transfer Queue.XML file which, in Properties showed a modified date of Feb 22nd and a last Accessed date of March 5th (Today). I could copy that file here to you but thought I'd ask first to avoid exposing either your secrets or mine! Near as I can tell though the information in there does not seemed to have changed; it makes reference to:

Version 1

The files referenced ar the same ones I've been experimenting with but they are really the only files I've needed to transfer and it's always been the same group of files. For each file:

-Start Time of 2007-02-22T16:52:19
-Finish Time of 1969-12-31T18:00:00 (that doesn't sound right!)
-Source and destinations look right

FYI, Here's a log of one of the files from Experiment #3 in which, at one point, I resaved the original html files to refresh them. Smart FTP rightly did not transfer when the file had not changed and did transfer when it had changed. (I X's out the IP address):

[08:40:44] 213 7131
[08:40:44] MDTM home.html
[08:40:44] 213 20070305143401
[08:40:44] Source File: Size=7131, SizeUnit=Byte, Time=2007-03-05T13:57:16, TimeFormat=Exact
[08:40:44] Destination File: Size=7131, SizeUnit=Byte, Time=2007-03-05T14:34:01, TimeFormat=Exact
[08:40:44] Rule "IF Destination Time=Newer AND Size=Equal AND Transfer=No Matter THEN Skip" matched. Action="Skip".
[08:40:44] Skipping file "home.html". Reason: User action.
[08:41:44] Remote file exist check: "home.html".
[08:41:44] SIZE home.html
[08:41:44] 213 7131
[08:41:44] MDTM home.html
[08:41:44] 213 20070305143401
[08:41:44] Source File: Size=7131, SizeUnit=Byte, Time=2007-03-05T13:57:16, TimeFormat=Exact
[08:41:44] Destination File: Size=7131, SizeUnit=Byte, Time=2007-03-05T14:34:01, TimeFormat=Exact
[08:41:44] Rule "IF Destination Time=Newer AND Size=Equal AND Transfer=No Matter THEN Skip" matched. Action="Skip".
[08:41:44] Skipping file "home.html". Reason: User action.
[08:43:04] Remote file exist check: "home.html".
[08:43:04] SIZE home.html
[08:43:04] 213 7131
[08:43:04] MDTM home.html
[08:43:04] 213 20070305143401
[08:43:04] Source File: Size=7131, SizeUnit=Byte, Time=2007-03-05T14:42:04, TimeFormat=Exact
[08:43:04] Destination File: Size=7131, SizeUnit=Byte, Time=2007-03-05T14:34:01, TimeFormat=Exact
[08:43:04] No rule matched. Default Action="Overwrite".
[08:43:04] PASV
[08:43:04] 227 Entering Passive Mode (XX,XX,XXX,XX,XX,XX)
[08:43:04] Opening data connection to XX.XX.XXX.XX Port: XXXXX
[08:43:04] STOR home.html
[08:43:04] 150 Accepted data connection
[08:43:05] 7131 bytes transferred. (63.3 KB/s) (110 ms)
[08:43:07] 226-File successfully transferred
[08:43:07] 226 2.349 seconds (measured here), 2.96 Kbytes per second
[08:43:07] MDTM 20070305144204 home.html
[08:43:07] 550 Can't check for file existence
[08:43:07] SIZE home.html
[08:43:07] 213 7131

Hello ..

I believe the main problem is that your Transfer Queue isn't restored after you restart SmartFTP. Install the latest beta version from:
Then go to the Transfer Queue and click on the "Save As.." button. Select a file where you want to save it.
Restart SmartFTP


I insatalled the new Beta and, Whoopeee! The files are there!


I'll report back on how this works with my Sheduled task setup.

Scheduled tasks trick works fine. It's all automatic now!

I've been trying to get SmartFTP to run in the background, like a Windows Service that starts automatically.

I've configured a Scheduled Task to start on System Start but although it starts it does nothing apparently. Did you manage to get it working in this way?

If you can help, please reply to my post "SmartFTP and the Windows Scheduler"

Scheduled tasks trick works fine. It's all automatic now!