An established connection was aborted by the software in your host machine.

macklebee

2007-01-08 20:14:56

I have been using SmartFTP for several months with no issues. I have been using it to connect to linux servers which were replaced last week with window servers. Now I am getting the above mentioned error.

I have tried several things listed in the forums that seemed relevent (and several that do not!!!)

So far I have tried the following (in no particular order):
Made a FTP rule in Norton Security to allow either direction communication.
Made sure SmartFTP had 'Permit ALL' Internet access in Norton Security.
Unchecked the 'Unused Windows Service Block' under Trojan Horse Rules in Norton Security.
Made sure Windows Firewall had SmartFTP as an exception.
Disabled both Norton Secrurity and Windows Firewall, and tried various mixes of enabled/disabled.
Removed hotfix kb937066 (if i remember correctly)
Tried Passive and Active Data Connection Modes with no luck.
Tried Auto/ASCII/Binary data transfer types
Tried all and no directory listing options (and each option independently) with no luck
Had another SmartFTP user try to connect with their computer and they were able to access the files with no problems.
Bought the licensed version today in hopes that would fix the issue... but no luck

This problem just occurred when I tried to connect to the new window servers. Last week I did not have any issues connecting to the linux servers (which are unfortunately down now).

Here is my log:
[14:08:47] SmartFTP v2.0.1001.7
[14:08:47] Resolving host name "208.100.57.130"
[14:08:47] Connecting to 208.100.57.130 Port: 21
[14:08:47] Connected to 208.100.57.130.
[14:08:47] 220- Welcome to LowPingGaming FTP Server!
[14:08:47] 220- You are being watched so you better be the one that is supose to be here.
[14:08:47] 220 Your IP Address has been recorded.
[14:08:47] USER AHTK
[14:08:47] 331 Password required for AHTK
[14:08:47] PASS (hidden)
[14:08:47] 230 User successfully logged in.
[14:08:47] SYST
[14:08:47] 215 UNIX emulated by Game-Panel FTP Server.
[14:08:47] Detected Server Type: UNIX
[14:08:47] FEAT
[14:08:47] 211-Extensions supported
[14:08:47] SIZE
[14:08:47] MDTM
[14:08:47] 211 END
[14:08:47] TYPE I
[14:08:47] 200 Type set to BINARY
[14:08:47] REST 0
[14:08:47] 350 Restarting at 0.
[14:08:47] PWD
[14:08:47] 257 "/" is current directory.
[14:08:47] TYPE A
[14:08:47] 200 Type set to ASCII
[14:08:47] PORT 192,168,1,103,8,137
[14:08:47] 200 Port command successful.
[14:08:47] LIST
[14:08:48] 150 Opening ASCII mode data connection for directory list.
[14:08:58] 421 Failed to create data connection socket.
[14:08:58] Automatic failover of data connection mode from "Active Mode (PORT)" to "Passive Mode (PASV)".
[14:08:58] PASV
[14:09:00] An established connection was aborted by the software in your host machine.
[14:09:00] Server closed connection

and here is my system info:
+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 2 (Build 2600)

CPU Speed : 2188 MHz
Total Memory : 981480 KB
Free Memory : 528340 KB

+- SmartFTP ---------------------------
Version : 2.0.1001.7
Time Stamp : 2007-01-08 08:19:55
Platform : x86

+- Application DLL --------------------
sfFTPLib.dll : 1.5.9.3
SmartHook.dll : 1.0.2.1

+- Language ---------------------------
SmartFTP.exe : 2.0.1001.7

+- System DLL -------------------------
shell32.dll : 6.00.2900.2951 (xpsp_sp2_gdr.060713-0009)
shlwapi.dll : 6.00.2900.2995 (xpsp_sp2_gdr.060913-0010)
comctl32.dll : 6.0 (xpsp.060825-0040)
riched20.dll : 5.30.23.1221
schannel.dll : 5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)

+- Internet Explorer ------------------
Version : 6.0.2900.2180

+- Winsock ----------------------------
Winsock : 2.2


PLEASE HELP!!!!!!!!!!!

mb

2007-01-09 05:25:17

Hello ..

Please add your license key id to your forum profile.

Thanks
-Mat