Unable to keep last folder view

I just upgraded to 2.0.996. Somehow the behavior changed. The application is no longer able to keep the last viewed window. I don't mind much about the remote connection, but I would like the local browser to stay up. I tried to save workspace, but unable to do so either. It's as if nothing was recorded or saved.

Please help.

Please enter your license ID in your forum profile for premium support. Choosing to save the workspace should do it. If you quit while you are connected to a remote server, does that connection window get restored?

I've entered my license ID, sorry about that.

I tried to save the workspace, but none can be saved.
If I quit when connected to a remote server, same thing happened. When I restart, the only window appeared is the the 4 below (temporary queue, transfer queue, connections, speed) came default during the update. Eventhough I chose to close 3 of them, the next time I started the app, still 4 reappear, and no last local or remote windows.

In addition, the buttons for layout are dimmed on the menu bar, so I can only use the menu selection under "window" to change it.
Strange thing is, I remember seeing a smartftp.ini before, but I can't find it now.

Hello ..

Send the information from the Help->About "System information" dialog.

Make sure you have the "Save Workspace" option enabled in the global settings -> Interface.


System Information as follow:

+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 2 (Build 2600)

CPU Speed : 1694 MHz
Total Memory : 1047408 KB
Free Memory : 446720 KB

+- SmartFTP ---------------------------
Version : 2.0.996.10
Time Stamp : 2006-04-10 16:30:55
Platform : x86

+- Application DLL --------------------
sfFTPLib.dll :
SmartHook.dll :

+- Language ---------------------------
SmartFTP.exe : 2.0.996.10

+- System DLL -------------------------
unicows.dll : 1.0.4018.0
shell32.dll : 6.00.2900.2869 (xpsp_sp2_gdr.060316-1512)
shlwapi.dll : 6.00.2900.2861 (xpsp_sp2_gdr.060303-1517)
comctl32.dll : 6.0 (xpsp_sp2_rtm.040803-2158)
riched20.dll :
schannel.dll : 5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)

+- Internet Explorer ------------------
Version : 6.0.2900.2180

+- Winsock ----------------------------
Winsock : 2.2

As for Make sure you have the "Save Workspace" option enabled in the global settings -> Interface, there's no such setting to enable, but there is a checkbox that's ticked currently to restore workspace on start.

On top of all the problems reported, the app windows also always default back to the first installed size, quite small. I always have to enlarge it. Unlike previous application, it saves the last setting. It's as if there is not settings being recorded for smartftp anywhere. The fact that I can't find any smartftp.ini, I wonder if you changed your new app to store settings in the registry, but it's definitely not saving anything.

Hello ..

SmartFTP never saved anything into a smartftp.ini. The problem might be with your registry permissions.
To fix it do the following:
- Close SmartFTP
- Open "regedit.exe" and then delete the following key:
- Start SmartFTP


You were right, permission problem with the registry. I did not delete the key, but instead I simply reassign the right permission, and voila it worked. Thanks.