What gives? Copy URL Problem

dcloud

2006-02-05 01:45:10

When I place a file into a folder on my remote server I like to right-click and copy the URL. I have to set the URL preferences in the Favorites folder first, which I have done. With the older version I would select my remote account (in the window at the left) right-click and choose "Add to Favorites". I notice this is not an option now, and I have to go up to the Favorites on the File menu and choose it there.

Kind of annoying, but anyway ... so once I add it to the Favorites I choose Edit Favorites, but I don't see it listed there. With the older version my server name was always at the bottom of the list on the right. So now I have to go searching each folder in the list on the left to find it, and I find it in Quick Connect. Why its there I have no idea. So I right-click my server name, select Properties, and go to the General URL window. I set my URL in the box, click OK and go back.

I continue to get nothing when I choose Copy URL for the file. So I go back into Edit Favorites and delete my server name from the Quick Connect folder. I go through the process again of adding my server name to the Favorites, only this time it places it where it should be - at the bottom of the list on the right (instead of in the Quick Connect folder).

Now I can copy the URL and it works fine, but my question is this: I have used SmartFTP for a long time and I just paid for the program because I thought I should since I use it a lot and I love it. But why now that I buy the program do I have to go through this dumb hassle with adding something to the Favorites when it was o utterly simple in the old version?

- dc

dcloud

2006-02-06 00:36:21

Anyone? C'mon, I expected a response of some kind. I'll give you SMFTP people one more day then I'm going to ask for a refund and go back to using the trial version.

- dc

mb

2006-02-06 06:50:06

Post your license key id when requesting support.

eyebex

2006-02-06 08:25:13

Or even better: Enter the ID into your forum profile in the proper field.

dcloud

2006-02-12 22:13:31

Ok, license key added, per your request. And as for the other issue I was haviing I resorted to figuring it out myself. It still doesn't work as smoothly as the old free version - sometimes it doesn't place the server name in the right spot and I have to spend time placing it there myself and it doesn't always "copy" the URL - but it's better than nothing I guess.

- dc

eyebex

2006-02-13 07:50:47

The concept of history / favorite entries has changed in 2.0. Every site you connect to through the address bar (i.e. not using an existing favorite) is now automatically added to the favorites in the quick connect folder, there is not need to chose "Add to Favorites ..." in this case. Instead of deleting it there and manually recreating it, why don't you just go to the favorite manager and drag & drop the favorite to the desired position, possibly also renaming it?

Are you saying the "Copy URL" feature doesn't work for favorites that have been automatically added to the QUick Connect folder? Please test with the latest build from my footer and try to reproduce this for a bug report, because here everything seems to be fine.

dcloud

2006-02-13 14:01:52

While everything there seems to be fine, it is not fine here.....

I cannot drag and drop to the Favorites editor. I have tried repeatedly, and nothing happens. Doing this I discovered another annoying thing about this new version - when I drag anything to another window my mouse pointer disappears, so I can't tell where I might be dropping the item. Also I have tried clicking the "Add to Favorites" button on the menu bar at the top of the remote browser window, and although it does add the server name to the Quick Connect folder, I still cannot copy any URLs this way. So ....

Now I have to manually add the server name to the main window of the Favorites editor by highlighting the server name in the remote window, going to the file menu and choosing Favorites>Add to Favorites, then I have to go into the Favorites editor, highlight the server name, choose Properties, and enter the main URL/Root Path manually, and even then it will only copy the URL after I shut the program down and restart it. I may have to do this several times before it works.

FYI: I have the latest "build"

- dc

eyebex

2006-02-13 16:06:01

dcloud

2006-02-14 04:24:40

I don't understand the "like the System Information from the Help -> About menu" ... you mean the Help>About in the Everest file menu?

I have restarted my PC many times and I still have the disappearing cursor whenever I try to drag something to another window.

I'm a graphic designer so being able to right click a file in the server window choosing "Copy URL>HTTP" is very useful. This is what I've been talking about: not being able to "Copy URL>HTTP" as easily as the free older version I had.

I am glad it works for you. That must be nice. Unfortunately it doesn't do me a lot of good.

- dc

Aokromes

2006-02-14 08:10:32


I don't understand the "like the System Information from the Help -> About menu" ... you mean the Help>About in the Everest file menu?


No, he means SmartFTP's Help->About->System Information.

dcloud

2006-02-19 13:29:09

My version was 2.0.993.25, but I got the update to 2.0.994.8. It hasn't changed anything.

eyebex

2006-02-19 13:33:42

Just download in from my footer.