SmartFTP suddenly ceased to work

Granny

2005-11-29 23:05:30

I have been using a licensed version for some time now with no problems....until this afternoon. Suddenly I am unable to stay connected long enough to see a file list. I am able to upload files through another source, so my webhost is not the problem. I have updated to the latest version (1.5.991.19) and have still not resolved the problem. Here is the log from my last try:
SmartFTP v1.5.990.11
Resolving host name "66.70.181.126"
Connecting to 66.70.181.126 Port: 21
Connected to 66.70.181.126.
220 plus22.host4u.net FTP server ready.
USER grannysjewelrybox
331 Password required for grannysjewelrybox.
PASS (hidden)
230 User grannysjewelrybox logged in.
SYST
215 UNIX Type: L8
FEAT
500 'FEAT': command not understood.
TYPE I
200 Type set to I.
REST 0
350 Restarting at 0. Send STORE or RETRIEVE to initiate transfer.
PWD
257 "/home/grannysjewelrybox" is current directory.
CWD /home/grannysjewelrybox/www/cgi-bin
250 CWD command successful.
PWD
257 "/home/grannysjewelrybox/www/cgi-bin" is current directory.
PASV
227 Entering Passive Mode (66,70,181,126,237,62)
Opening data connection to 66.70.181.126 Port: 60734
LIST -aL
Timeout (20s).
Active Help: https://www.smartftp.com/support/kb/74
Client closed the connection.
Automatic failover of data connection mode from "Passive Mode (PASV)" to "Active Mode (PORT)".


I followed the instructions for changing the connection timeout to 40s, but that doesn't seem to help as it still timesout at 20s, no matter what. Help!

mb

2005-11-29 23:21:29

If you are connecting through a favorite item, you need to change the timeout setting there. Go to menu: Favorites->Edit Favorites, select the favorite item, right-click on it and select "Properties" from the context menu. Then go to the Connection dialog and change the timeout value to 60 seconds.

If you are still having problems, change the data transfer mode from "Passive Mode" to "Active Mode" and try again.

Regards,
-Mat

Granny

2005-11-29 23:40:28

Thanks Mat. Changing to active mode worked. I don't understand why passive mode suddenly stopped working though.....any ideas?

eyebex

2005-11-30 00:02:49

This can be caused by firewall configuration changes on the server side.

Granny

2005-11-30 03:06:38

Since I upgraded to the most current build of SmartFTP (1.5.991.19) I am connected automatically to the server when I open the SmartFTP application. Is this a bug with the new version? I prefer to decide when to connect and can find nothing in settings to control this. License key 400013475
Thanks,
Pat Hamm

eyebex

2005-11-30 07:55:02

There is a new feature in this version, called "workspaces". Workspaces save the complete state the application is in, incl. window positions and connected servers. Under "Tools" -> "Settings", "Interface", uncheck "Automatically save workspace on exit". If you do not want this behavior. Workspaces can the managed through "Window" -> "Wordspace" -> "Manage ...".