[F7] Edit not working in latest version

I just updated to the latest version 2.5.1008. I regularly use F7 to edit some text files on my remote FTP server. This use to load up the text file in Notepad and wait for me to save the text file and it would be uploaded automatically.

Now I get the filename appearing in the queue area which I'm sure didn't happen before and is probably not desirable, but the file is never loaded into Notepad.

Any ideas?

If you have the "Default Drag&Drop operation" option in the menu: Tools->Settings "Navigation" dialog set to "Queue" then all edit operations will be handled by the Transfer Queue. You can set the option to "Direct" and the old edit method will be used. Or if you use the new method make sure that the Transfer Queue is started.


That resolved it for me. It appears there is a problem when upgrading from a previous version. I do have the queue activated as I use that for uploading files regularly. When I pressed [F7], it came up [Monitoring] in the Status column but it would not load the file editor (Notepad). After setting the Drag&Drop operation to Direct and then back to Queue, it is now working correctly.


I have to come back to this problem. I changed the Default Drag&Drop operation to Direct but then found my copy/pastes that I do regularly to upload files were then also direct rather than queued which is no good for me, so I've changed back to Queue.

But now the problem is occuring again. If I press F7 on a .txt file, the queue status says the following but no edit window (Notepad) opens.

xx bytes transfered
Prompt to close down SmartFTP which I have selected for OnQueueComplete

There are 2 problems. The first being Notepad not opening, and the second is I want the OnQueueCompleted for when I'm uploading or downloading files, but not when editing files. So I much prefer the previous version which had F7 always Direct and drag&drop Queued. Is there any way to get this behaviour back again? Perhaps a separate option for these 2 operations.


We will look into it.