Show Raw Listing opens blank Notepad

When I use the Show Raw Listing command it opens a blank version of Notepad with no listing. Occasionally, there is a Notepad pop-up notification "Cannot find the .txt file. Do you want to create a new one?". I am using SmartFTP 2.5 and have tried restart, uninstall/reinstall and installing the version 3 beta but get the same problem. I have tried Raw Listing on two remote servers where I have accounts and on public servers such as A typical log entry when connected to is:

[10:51:15] Opening data connection to Port: 61516
[10:51:15] LIST
[10:51:15] 412 bytes transferred. (3.21 KB/s) (125 ms)
[10:51:15] 150 Opening ASCII mode data connection for /bin/ls.
[10:51:16] 226 Transfer complete.

I have also tried changing the List Arguments in the Favourites > Properties > Transfer

My SmartFTP System Info is shown below.




+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 2 (Build 2600)

CPU Speed : 1599 MHz
Total Memory : 494 MB
Free Memory : 46 MB

+- SmartFTP ---------------------------
Version : 2.5.1008.37
Time Stamp : 2008-02-01 00:10:32
Platform : x86

+- Application DLL --------------------
sfFTPLib.dll :
sfFavorites.dll :
sfFavoritesShellExtension.dll :
sfTransferQueue.dll :
SmartHook.dll :

+- Language ---------------------------
SmartFTP.exe : 2.5.1008.37

+- Internet Explorer ------------------
Version : 6.0.2900.2180

+- Winsock ----------------------------
Winsock : 2.2

Hm I can't reproduce it. What's the full path to your temporary folder?

For example on my Vista system its:


Good idea. My temporary folder is at C:\Documents and Settings\Tim\Local Settings\Temp. A .tmp file such as "sf117.tmp" is being written to this folder after a "Show Raw Listing" and it does seem to have the correct info. I have copied an example of a listing of a directory containing six image files at the end of this note.

I still get a blank Notepad even though I have made Notepad the default for .tmp files. Do I just have to put up with this and manually open the .tmp file in the Temp folder as a workaround?

Thanks for your help


=32168;unique=808g934056; .
=32168;unique=808g934040; ..
=32168;unique=808g93419f; basket.gif
=32168;unique=808g9341a0; checkout.gif
=32168;unique=808g9341a1; help.gif
=32168;unique=808g9341a2; logo.gif
32168;unique=808g9341a3; pix.gif
2168;unique=808g9341a4; spacer.gif

Hello ..

Version 3.0 beta uses a .txt file extension instead of the .tmp extension. Also I have back ported the changes to version 2.0. The next build of 2.0 will include the fix.
Thank you for your feedback.