"Windows" Toolbar visibility not saved

Since using SmartFTP 2.5.* I've noticed the "Windows" toolbar becomes visible each time I run SmartFTP. I hide it each time I run, but the next time it's always there.

I have tested this in the most recent beta (2.5.1006.1) and the bug is still present.

Steps to reproduce this error:
  1. Start SmartFTP.
  2. Untick the Tools > Tabbed Interface menu.
  3. Select Tools > Options.
  4. Navigate to the Interface page.
  5. In the Look section, set the Theme dropdown to Native Windows.
  6. Click OK.
  7. Right-click on the menu bar.
  8. Untick all of the following:
    1. Standard
    2. Windows
  9. Now open a new Remote Browser window. (I do this from the History toolbar.)
  10. Right-click the Remote Browser toolbar.
  11. Untick all of the following:
    1. Navigation
    2. Remote
    3. Command Line
  12. Note that the Windows toolbar is not visible. (The History toolbar should be the only visible one.)
  13. Close SmartFTP.
  14. Start SmartFTP.
  15. Note that the Windows toolbar is visible.
I can provide screenshots if these would be helpful.

System Info:
+- System -----------------------------

Microsoft Windows XP Home Edition 

Service Pack 2 (Build 2600)

CPU Speed		 : 1410 MHz

Total Memory	  : 511 MB

Free Memory	   : 261 MB

+- SmartFTP ---------------------------

Version		   : 2.5.1006.1

Time Stamp		: 2007-05-31 06:15:30

Platform		  : x86

+- Application DLL --------------------

sfFTPLib.dll	  :

sfFavorites.dll   :

SmartHook.dll	 :

+- Language ---------------------------

SmartFTP.exe	  : 2.5.1006.1

+- Internet Explorer ------------------

Version		   : 7.0.5730.11

+- Winsock ----------------------------

Winsock		   : 2.2

I like nearly everything about SmartFTP. One thing I don't like is how increasingly over-stylised and cluttered the UI gets with each release. Thankfully you guys realise weirdos like me exist and provide options which tone it down and tidy it up. This is only a small bug but I like having a minimal UI. Life is complicated enough already.

Yep, that's working fine for me now. Thanks!