Problem with Vista (Local Browser not showing files)

I recently installed Vista Ultimate on my laptop, replacing XP Pro, and am having an unexpected problem with Smart FTP, version 2.0.1002.

For the local directory, the "details" view is empty. The list, small icons, and large icons views display normally.

I prefer the details view as it lets me sort to put the most recently altered files at the top.

Anyone else able to confirm this problem?


Could you please install the latest version from:

No improvement - sorry!

At the very top of the local area on both versions are strange black bands. I can post a photo if that helps.


Hello ...

I would appreciate if you can post a screenshot.

Thank you

I just tried running as Admin, and got the same results, but clicking back and forth between the left directory and empty areas on the local area seemed to be finding files that were invisible to me. Suddenly everything appeared normally.

This will take some experimentation, as I don't know whether it's your new version, the administrative account, or whether clicking back and forth on the directory somehow cleared/reinitialized a critical data area.

This is a vaguer answer than I like to give; clearly something strange is going on. But I'm appreciative of the new version.


Alas, for purposes of debugging, the problem seems to have been eliminated. It is working correctly across reboots and under my normal logon.

I'm sorry I didn't get a screenshot; this would have raised your proverbial eyebrows.

I'm obviously appreciative of the quick interest and response from SmartFTP.


Hi Guys

I'm having the same thing here. I have tried downloading from the link above, but still the same thing. The other thing I keep having, is that Smart FTP crashes (Stops Responding) when I mouse over the menu at the top. Sometimes it works 100% and sometimes, as I mouse over the menu, just before it drops down, it stop responding. I have tried running it as Admin, and with WinXP SP2 compatability.

Any Ideas?


I have managed to get a screenshot Image.


I have tried it and still the same thing. If I use the different views it works fine, exept the "Details" view, which is the one I use.


Hello ..

Please post the system information from the Menu: Help->About "System Information" dialog.
Thank you.

Hi Mat,

The system info as requested:

+- System -----------------------------
Microsoft Windows Vista Business Edition
(Build 6000)

CPU Speed : 1994 MHz
Total Memory : 1014 MB
Free Memory : 206 MB

+- SmartFTP ---------------------------
Version : 2.5.1005.5
Time Stamp : 2007-03-27 04:28:24
Platform : x86

+- Application DLL --------------------
sfFTPLib.dll :
SmartHook.dll :

+- Language ---------------------------
SmartFTP.exe : 2.5.1005.5

+- System DLL -------------------------
unicows.dll : 1.0.4018.0
shell32.dll : 6.0.6000.16386 (vista_rtm.061101-2205)
shlwapi.dll : 6.0.6000.16386 (vista_rtm.061101-2205)
comctl32.dll : 6.10 (vista_rtm.061101-2205)
riched20.dll :
schannel.dll : 6.0.6000.16386 (vista_rtm.061101-2205)

+- Internet Explorer ------------------
Version : 7.0.6000.16386

+- Winsock ----------------------------
Winsock : 2.2


Thank you.

As we are unable to reproduce the problem we need to run a remote debug session to see what's exactly going on. Please contact us if you are interested to volunteer ;-)


Hi Mat,

Sure, what do I need to do.

Hi All,

I re-installed Vista from scrath, and then installed SmartFTP on the machine without installing anything else. SmartFTP seems to work 100%. It looks to be something installed on my machine. Will try and replicate the error sometime and let you all now!

Thanks to Mat for all his assistance!

Kind Regards


I found my problem. I moved my favourites etc from my WinXP machine to Vista, and imported my registry settings. Not a good idea. Rather backup and restore your settings using SmartFTP!