Connection error

Is there a restriction in the length of a username? I cannot connect to my host using SmartFTP. I am trying to load files into a friend's webspace on SHAW. The webspace was finally loaded using CuteFTP, but I still cannot connect to it using SmartFTP (login failure). The webspace is
The host is, username is kjenkinsbookkeeping, and password contains six letters.
My system info is
+- System -----------------------------
Microsoft Windows XP Home Edition
Service Pack 2 (Build 2600)

CPU Speed : 1398 MHz
Total Memory : 244144 KB
Free Memory : 110708 KB

+- SmartFTP ---------------------------
Version : 2.0.996.31
Time Stamp : 2006-06-10 04:36:06
Platform : x86

+- Application DLL --------------------
sfFTPLib.dll :
SmartHook.dll :

+- Language ---------------------------
SmartFTP.exe : 2.0.996.31

+- System DLL -------------------------
shell32.dll : 6.00.2900.2869 (xpsp_sp2_gdr.060316-1512)
shlwapi.dll : 6.00.2900.2904 (xpsp_sp2_gdr.060509-0218)
comctl32.dll : 6.0 (xpsp_sp2_rtm.040803-2158)
riched20.dll :
schannel.dll : 5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)

+- Internet Explorer ------------------
Version : 6.0.2900.2180

+- Winsock ----------------------------
Winsock : 2.2


Here is the log --

[08:18:28] SmartFTP v2.0.996.31
[08:18:28] Resolving host name ""
[08:18:28] Connecting to Port: 21
[08:18:28] Connected to
[08:18:28] 220 Shaw FTP Server Ready
[08:18:28] USER kjenkinsbookkeeping
[08:18:28] 331 Password required for kjenkinsbookkeeping.
[08:18:28] PASS (hidden)
[08:18:28] 530 Login incorrect.
[08:18:28] Active Help:
[08:18:28] Cannot login waiting to retry (30s)...

However, read post below.

I read the information about preparing to file a bug report. I didn't know how to deinstall SmartFTP Client, so I ran the updates and carried on. Just now, the drop down menu (Start > All Programs > SmartFTP >) gave that option. I did so and then tried to run SmartFTP and it automatically reloaded it. I then tried to login to my friend's account and IT WORKED! That makes me feel a little stupid, but things are still a little confusing, because now the deinstall option no longer appears on the drop down menu. Does this mean I should run the updates again??
Thanks for your cooperation and patience.