Timeout (0s)

bramtops

2006-03-31 11:41:37

Hi. I'm considering new FTP clients for our department and I've stumbled across SmartFTP. I like the way it works and it's 'robust' feeling.

But I have the most annoying bug. The client closes connections with a
[13:27:40] Timeout (0s).
[13:27:40] Active Help: https://www.smartftp.com/support/kb/74
[13:27:40] Client closed the connection.
error.

This happens when uploading, downloading and even getting a listing (LIST -a). The connection time-out in my Settings obviously isn't configured that way. I've tried high, low, normal and the default numbers. It doesnt matter. Als checked most other options too, to see if i could discover any relation. Unsuccesfully though. Sometimes the client just refuses to do anything by 'timing out' after 0 seconds.

It's server independant and I've tried every option that could remotly have anything to do with this.

I've tried latest stable and latest beta.

Some logs:

a simple login:

[13:27:27] 230 User XXXXX logged in.
[13:27:27] SYST
[13:27:27] 215 UNIX Type: L8
[13:27:27] FEAT
[13:27:27] 211-Features:
[13:27:27] MDTM
[13:27:27] REST STREAM
[13:27:27] SIZE
[13:27:27] 211 End
[13:27:27] PWD
[13:27:27] 257 "/" is current directory.
[13:27:27] TYPE A
[13:27:27] 200 Type set to A
[13:27:27] PORT 172,20,40,41,14,29
[13:27:27] 200 PORT command successful
[13:27:27] LIST -a
[13:27:27] 150 Opening ASCII mode data connection for file list
[13:27:27] 918 bytes transferred. (N/A/s) (0 ms)
[13:27:27] 226-Transfer complete.
[13:27:27] 226 Quotas off
[13:27:39] CWD /httpdocs
[13:27:40] 250 CWD command successful.
[13:27:40] PWD
[13:27:40] 257 "/httpdocs" is current directory.
[13:27:40] PORT 172,20,40,41,14,31
[13:27:40] 200 PORT command successful
[13:27:40] LIST -a
[13:27:40] Timeout (0s).
[13:27:40] Active Help: https://www.smartftp.com/support/kb/74
[13:27:40] Client closed the connection.

A file upload (queue):

[13:37:08] Resolving host name "ftp.XXXXXXXX.nl"
[13:37:08] Connecting to 217.21.242.130 Port: 21
[13:37:08] Connected to ftp.XXXXXXXX.nl.
[13:37:09] 220 ProFTPD 1.2.9 Server (ProFTPD) [totalsupport-managed]
[13:37:09] USER XXXXXXX
[13:37:09] 331 Password required for XXXXXXXX.
[13:37:09] PASS (hidden)
[13:37:09] 230 User XXXXXXX logged in.
[13:37:09] SYST
[13:37:09] 215 UNIX Type: L8
[13:37:09] FEAT
[13:37:09] 211-Features:
[13:37:09] MDTM
[13:37:09] REST STREAM
[13:37:09] SIZE
[13:37:09] 211 End
[13:37:09] PWD
[13:37:09] 257 "/" is current directory.
[13:37:09] CWD /httpdocs/video
[13:37:09] 250 CWD command successful.
[13:37:09] PWD
[13:37:09] 257 "/httpdocs/video" is current directory.
[13:37:09] Remote file exist check: "mobieltje.flv".
[13:37:09] TYPE I
[13:37:09] 200 Type set to I
[13:37:09] SIZE mobieltje.flv
[13:37:09] 213 49152
[13:37:09] MDTM mobieltje.flv
[13:37:09] 213 20060331113708
[13:37:09] Rule "IF Destination Size=Smaller AND Time=Recent AND Transfer=No Matter THEN Delete First" matched. Action="Delete First".
[13:37:09] DELE mobieltje.flv
[13:37:09] 250 DELE command successful.
[13:37:09] PORT 172,20,40,41,14,90
[13:37:09] 200 PORT command successful
[13:37:09] STOR mobieltje.flv
[13:37:09] 150 Opening BINARY mode data connection for mobieltje.flv
[13:37:09] Transfer Timeout (0s). Closing data connection.
[13:37:09] 47104 bytes transferred. (63.7 KB/s) (721 ms)
[13:37:10] 226 Transfer complete.
[13:37:10] SIZE mobieltje.flv
[13:37:10] 213 47104
[13:37:10] File size mismatch.
[13:37:10] Resolving host name "ftp.XXXXXX.nl"
... connects again and starts from top

Please help! I'm really starting to like SmartFTP, but this thing is rendering it useless for us

Aokromes

2006-03-31 13:09:14

Hi, [[[TRYPASVPORT][/TRYPASVPORT]][/[TRYPASVPORT][/TRYPASVPORT]]][/[[TRYPASVPORT][/TRYPASVPORT]][/[TRYPASVPORT][/TRYPASVPORT]]]

bramtops

2006-03-31 13:36:37

Nope:

[15:31:55] 220 ProFTPD 1.2.9 Server (ProFTPD) [xxxxxx]
[15:31:55] USER XXXXXXX
[15:31:55] 331 Password required for XXXXXXXX.
[15:31:55] PASS (hidden)
[15:31:55] 230 User XXXXXXXX logged in.
[15:31:55] SYST
[15:31:55] 215 UNIX Type: L8
[15:31:55] FEAT
[15:31:55] 211-Features:
[15:31:55] MDTM
[15:31:55] REST STREAM
[15:31:55] SIZE
[15:31:55] 211 End
[15:31:55] PWD
[15:31:55] 257 "/" is current directory.
[15:31:55] TYPE A
[15:31:55] 200 Type set to A
[15:31:55] PASV
[15:31:55] 227 Entering Passive Mode (217,21,242,130,10,182).
[15:31:55] Opening data connection to 217.21.242.130 Port: 2742
[15:31:55] LIST -a
[15:31:56] Timeout (0s).
[15:31:56] Active Help: https://www.smartftp.com/support/kb/74
[15:31:56] Client closed the connection.

And as i stated in my first post: I already tried those obvious options!

Why doesnt this little line surprise you?!?!
[15:31:56] Timeout (0s).

Why does the client suddenly have a instant-timeout configuration?!

eyebex

2006-03-31 13:39:38

Have you made sure you're editing the favorite item's timeout value, and not the global value?

bramtops

2006-03-31 14:48:51

Most favourites are on "use global settings". But it doesnt matter actually. I can specify anything I want anywhere I want and I still occaisionly get the timeout (0s) error. With uploading, downloading, 'list'ing, large files, small files, binary-transfer, ascii-transfer....

Other FTP clients work like they should at (almost) the same time..

eyebex

2006-03-31 15:36:46

Exactly which version are you using after all? Please post the System Info from the About dialog here.

mb

2006-03-31 16:04:25

You have set the timeout value to 0. Change it either in the Global Settings or the in the Favorite Item settings. Set the timeout value to 30.

Regards,
-Mat

bramtops

2006-03-31 23:22:28


Exactly which version are you using after all? Please post the System Info from the About dialog here.
As i said in the first post, I've used the latest stable version (995 i believe) and the latest beta (996). Not really sure about the numbers though. I'm using the trial at work and i'm posting from my home PC atm. I'll post that info later.

I'm using (at work) a windows XP with a normal installation. Nothing fancy installed, just some programs i need to work with. No hacks/tweaks or whatever. We use a normal NAT. And only all the latest updates from MS. So nothing in my OS which could explain this behaviour.

bramtops

2006-03-31 23:32:38


You have set the timeout value to 0. Change it either in the Global Settings or the in the Favorite Item settings. Set the timeout value to 30.

Regards,
-Mat
Thanks for your time. But I really didnt set the timout value to 0. I'm a developer myself and have been working with internet protocols (all of 'm) for about a decade. I know what i'm talking about; I wouldn't have posted this here if i'd could think of any reason why i get this.

I'm testing this software to see if it would be of any use to us. I'll be frank. We've been using CuteFTP so far but i'm getting annoyed with it's behaviour. We're still using version 6, but 7 also displayed some issues i'm not looking for.

SmartFTP really has some things I like (and I've some suggestions which would really make me 'wet my pants') but this thing 'bug' (it might still be something thats on our side) is driving me nuts...

Could anyone please look over the code thats handling the time-outs? Thanks!

mb

2006-04-01 00:06:00

1. Update to the latest version
https://www.smartftp.com/download

2. Please post the System Information from the menu: Help->About.

3. Check the Global- and the Favorite Item settings for the Timeout value. If they are not set to 0 create a new favorite item through the menu: File->New Remote Browser. I'm not saying you have knowingly entered 0 into the timeout setting because it's also possible that the import function didn't work correctly. This could be the case if you were upgrading from version 1.1 or lower.

Regards,
SmartFTP

bramtops

2006-04-10 09:00:19

Hello again. Thought I'd post a small update.

It seams that the Timout (0s) can occur at any given moment. I've seen it appear at about every step in (for example) the log's i've posted above. Sometimes half a second after I connect, sometimes minutes later. When uploading, downloading, switching paths, geting listings, checking for file availability, CHMODding, etc.. So it doesn't seem to be a specific-action related problem.

The client just goes "Jeees.. I havent received anything in the pas 0,0 second. I dont care that I received something 0.1 second ago, thats a decade for a fast program like me! I'm going to disconnect now - stupid server!"

I haven't used the 1.x series. I have imported FTP-sites from the CuteFTP 6 (sm.dat) connection manager though. I've seen the problem with those imported sites, but also with 'freshly' created items in the favorites. The importing went fine by the way (not perfect: messed up some passwords), no other problems there.

I've just installed the latest beta (9, was running 2). Haven't seen the problem yet, but I've only used it for a few minutes.... *crosses fingers*

And the System Info (latest install):
+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 2 (Build 2600)

CPU Speed : 1707 MHz
Total Memory : 1048028 KB
Free Memory : 548776 KB

+- SmartFTP ---------------------------
Version : 2.0.996.9
Time Stamp : 2006-04-09 23:32:39
Platform : x86

+- Application DLL --------------------
sfFTPLib.dll : 1.5.8.3
SmartHook.dll : 1.0.2.1

+- Language ---------------------------
SmartFTP.exe : 2.0.996.9

+- System DLL -------------------------
shell32.dll : 6.00.2900.2763 (xpsp_sp2_gdr.050922-1642)
shlwapi.dll : 6.00.2900.2781 (xpsp_sp2_gdr.051020-1730)
comctl32.dll : 6.0 (xpsp_sp2_rtm.040803-2158)
riched20.dll : 5.30.23.1221
schannel.dll : 5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)

+- Internet Explorer ------------------
Version : 6.0.2900.2180

+- Winsock ----------------------------
Winsock : 2.2

bramtops

2006-04-10 13:56:21

Ok... just got another one with the latest beta

[14:18:47] 230 Login successful. Have fun.

[14:18:47] SYST

[14:18:47] 215 UNIX Type: L8

[14:18:47] FEAT

[14:18:47] Timeout (0s).

[14:18:47] Active Help: https://www.smartftp.com/support/kb/74

[14:18:47] Client closed the connection.

mb

2006-04-10 18:48:51

There was no change regarding the timeout in the .9 version. But try the .10 version from:
https://www.smartftp.com/download
This version will automatically change the timeout value if it has been set to 0.

Regards,
-Mat

bramtops

2006-04-11 10:10:35

Ok thanks! I'm testing it now. Will get back here later.

/edit: 13.36pm. Haven't had a single timeout yet, should've had one by now. Looking good.

bramtops

2006-04-20 14:20:55

Haven't had a single timeout since the last update. Allthough the time-out hasn't been set to 0 anywhere in my settings (and i mean anywhere) it seems version .10 has fixed the problem.

Thanks!