Drag and drop from local to remote folder

I just installed the latest built 2.995. Whenever now I try to upload a file, drag and drop works only on "closed" folders: it works when you drop the file on a folder in the tree of the remote browser, but it does not work when you drop the file on the right-hand side of the browser - the window where the files of the FTP server are displayed.

Nor does it work if you first drag the file to the queue or to the temparory queue and then to the remote window.

The other way around, from remote to local, everything works fine.

This problem has not been present in earlier releases (2.993 and earlier).

Tech info:

+- System -----------------------------
Microsoft Windows XP Professional
Service Pack 2 (Build 2600)

CPU Speed : 1595 MHz
Total Memory : 514416 KB
Free Memory : 243340 KB

+- SmartFTP ---------------------------
Version : 2.0.995.2
Time Stamp : 2006-02-16 13:20:49
Platform : x86

+- Application DLL --------------------
sfFTPLib.dll :
SmartHook.dll :

+- Language ---------------------------
SmartFTP.exe : 2.0.995.2

+- System DLL -------------------------
shell32.dll : 6.00.2900.2763 (xpsp_sp2_gdr.050922-1642)
shlwapi.dll : 6.00.2900.2781 (xpsp_sp2_gdr.051020-1730)
comctl32.dll : 6.0 (xpsp_sp2_rtm.040803-2158)
riched20.dll :
schannel.dll : 5.1.2600.2180 (xpsp_sp2_rtm.040803-2158)

+- Internet Explorer ------------------
Version : 6.0.2900.2180

+- Winsock ----------------------------
Winsock : 2.2

Sorry I'm unable to reproduce it. I belive you that you have to provide a couple of more details. Where are you draggingi from exacatly? Windows Explorer? Local Browser? from the tree control or the list control? Or you drag&dropping multiple files/folders?


Hi Mat

The drag & drop is from the local browser within SmartFTP, from the list control. To the list control of the remote browser.

Drag & drop a single file or multiple files, or a combination of both makes no difference: it works only when dropped on a remote folder-symbol (either in the tree control or the the list control).
The form of the cursor BTW confirms this: from local to remote, when hovering over the remote list control, it gives the "forbidden" sign (an O with a slash through it), only when hovering over a folder-symbol it changes to the box with the + sign.

The other way around, from remote to local, does work in all cases though. The cursor, when hovering over the list, is from remote to local in all cases the box with the + sign.

I have for several years now SmartFTP set up as follows:
I do use the queue (options-navigation-defaultdrag&drop=queue) but for downloading I drag&drop directly from the remote browser to the local browser, or when uploading directly from local browser to the remote.

Given this new problem, I tried to first drop the files from local to the queue, and then to the remote browser. With the same result: forbidden, unless dropped on a folder-symbol.

Hope this helps ...

OK .....


Hello ..

I'm sorry but I'm unable to reproduce it. Can you please create a movie showing the problem? See the Bug Report Readme for tools on how to screen capture your actions.


I just installed the latest version today and drag and drop from Windows Explorer to Smartfp doesn't work. Using Vista Home Premium.

Please post a movie showing the problem.


Hi everyone,

I'm having exactly the reverse problem: I can drag and drop a file from my local browser to the server (upload) but I cannot drag and drop a file from the server to my local browser (download).

I'm using XP SP2 and SmartFTP 2.5.1008 and I've not changed anything at all since installing this version (about 2 or 3 months ago). Everything was working perfectly last weekend when I downloaded a whole bunch of files. Today it refused to work.

I'm trying to drag a file from the 'files' pane on the server to the 'files' pane on my PC - exactly as I've always done.

Any suggestions would be very much appreciated!