Changed password, now I can't connect

I changed the password to our FTP on the ISP's site. I have multiple computers in multiple locations that are affected by this change. All other computers can connect to the FTP with the new password; my computer cannot. I have verified and verified and verified the ftp address, logon and password. The only thing that has changed is the password to access the site. When I try to connect I get the error message: "A conection attempt failed because the connected party did not properly respond after a period of time or established connection failed because connected host has failed to respond."
I have tried using FTP protocol and SFTP on ports 21 and 22 respectively with the same result.
I have used a command prompt to ping the ftp address and also the IP address with the result: "Destination port unreachable" for both ftp and ip addresses.
I have turned my antivirus firewall off. Windows firewall off... same thing... "Destination port unreachable"
I am officially stumped. The only thing that changed was the password. When I updated the password, I pasted it into the Password field and received a prompt asking if I wanted to update the favorite, which I accepted. No other changes were made to the logon credentials.
I would seriously appreciate help to resolve this issue.
I also installed and attempted to access the FTP using FileZilla with the same result. So something is blocking access to this ftp site. I have five other FTP sites that I connect with and the other four sites connect with no problem using SmartFTP. The only site that has been affected is the one with the password change.