Cannot connect to Server

Please help me. I've used FTP for a while to run my Dad's website. I had to reinstall my operating system recently to fix some other stuff, and now I cannot connect to my server through FTP. At first I was sure it was because I wasn't typing in the parameters right, like the username/password/ and address. But my dad went in (somehow, I have no idea) and changed the passoword, so I know that's not the problem. He says his username is like "" I've typed it in both as "xxx" and as "" neither work. Same for the address. I typed it in as "",", "" none of these variations work.
In the past, I have always had error messages unrelated to username/password that always ended up being fixed by figuring out how to enter the username/pass correctly. However this time I think it might actually be a different problem. Here's what I get:
"A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond."
I know that says nothing about username/pass but I was convinced that was really the problem secretly and am still not super convinced that it's not. I've been all over the net troubleshooting this. I've read all of FTP's troubleshooting things for this and haven't found anything that helps. I've confirmed that my server is not down. I've turned off all firewalls and anti-virus and everything like that (but FTP was allowed through anyway so I never thought that was it). 
What is going on?!?! My Dad is on my back because he needed this edit done yesterday and it would be a 2 second fix if I could just freaking connect to the thing. I'm on a home computer, no company firewall or anything. I am the only person ever who tries to access this site.
What am I doing wrong here, guys?
EDIT: SOLVED IT!!!! I just had to type "ftp." (so "") before the web name in the address bar. Well there go many hours of my life for a 3 letter mistake... oh well.