SmartFTP sometime preventing Dreamweaver FTP

I am considering replacing FTP Voyager with SmartFTP as my main FTP client. I am extremely impress with SmartFTP but came across 2 recurring issues:
1- In some case if I have SmartFTP open and I try to FTP to our server with Dreamweaver, DW will return an immediate failure error ("internal data error. failed to receive network data."). It does not do that all the time, but when this happen, closing SmartFTP will fix the issue and DW will be able to FTP again. When this happen I am not even necessarily working on the same website (although it is the same server). DW will return the error pretty much immediately. Very odd. I have research the web and this forum but so far no luck in finding a solution. May be something local with Windows 7 not letting access FTP port for the 2 softwares at the same time? Anyone came across such issue?
2- A file will sometime get "stuck" and not download/upload to the server and show as waiting to retry. The log in such case just show the connection as retrying and all file behind the one that does not want to upload waiting. Moving the file down the queue helps and sometime the file in question will eventually upload/download. This does not happen all the times and it does not look to be specific to the file type or file possibly being locked/in use on my desktop.
For both issues I tried to reproduce just now so I could provide further details but of course it works now. I will update this post next time this happen.
Thanks for your help,

Maybe your server limits the number of concurrent connections. By closing SmartFTP you will release the open connections which will allow other applications to use them.
If you dont want to wait for the retry, right-click on the item and select Process from the context menu. What is the reason (post log) why the item does not process?

Thanks for your response.
>1 We have our own server and there is no limit on number of connections. Also, I never had this issue with FTP Voyager. It really feels like it is a Windows 7 issue since it is so immediate. Would SmartFTP somehow block other outgoing FTP connection when on? I do have it set up with 8 "workers" typically. Very odd...
>2 Here again, I have little info unfortunately. Right clicking on the process and have it process does not always work. When this happen I end up stopping the transfer and deleting all the queue then try again. Next time this happen I will check again the log, but I don't remember noticing anything special there last time this occurred.