Connect failed. Error=0x80043112

I am receiving a 'Connect failed. Error=0x80043112' message when attempting to connect to an FTP host (21) using SmartFTP 4.1.1289.0 (Ultimate).
I have been able to successfully connect to other hosts from my machine so I don't think that it is a firewall issue on my side.
I am also able to connect to this specific host from another machine using SmartFTP 4.1.1289.0 (Pro).
Any suggestions?
Thank you.
Stephen Howard

I got the same error now in 5.0.1353.0. Connecting to the server has always worked fine (and still works fine over putty), but fails with SmartFTP.
[18:28:43] SmartFTP v5.0.1353.0
[18:28:43] Resolving host name "xyz"
[18:28:43] Connecting to x.x.x.x Port: 22
[18:28:44] Connected to ....
[18:28:44] SSH protocol version reply. Client Id: SSH-2.0-SmartFTP
[18:28:44] SSH-2.0-OpenSSH_6.5
[18:28:44] Starting SSH session. Remote Id: "SSH-2.0-OpenSSH_6.5"
[18:28:44] Server Algorithm Suite
           Key Exchange:,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
           Server Host Key: ssh-rsa,ssh-dss,ecdsa-sha2-nistp256,ssh-ed25519
           Client to Server Encryption: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,,,,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,
           Server to Client Encryption: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,,,,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,
           Client to Server HMAC:,,,,,,,,,hmac-md5,hmac-sha1,,,hmac-sha2-256,hmac-sha2-512,hmac-ripemd160,,hmac-sha1-96,hmac-md5-96
           Server to Client HMAC:,,,,,,,,,hmac-md5,hmac-sha1,,,hmac-sha2-256,hmac-sha2-512,hmac-ripemd160,,hmac-sha1-96,hmac-md5-96
           Client to Server Compression: none,
           Server to Client Compression: none,
[18:28:44] Selected Algorithm Suite
           Key Exchange:
           Server Host Key: ecdsa-sha2-nistp256
           Client to Server Encryption:
           Server to Client Encryption:
           Client to Server HMAC: none
           Server to Client HMAC: none
           Client to Server Compression:
           Server to Client Compression:
[18:28:44] Client Algorithm Suite
           Key Exchange:,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group1-sha1,diffie-hellman-group14-sha1,rsa1024-sha1
           Server Host Key: ecdsa-sha2-nistp256,ecdsa-sha2-nistp384,ecdsa-sha2-nistp521,x509v3-sign-rsa-sha1,x509v3-sign-dss-sha1,ssh-rsa,ssh-dss
           Client to Server Encryption:,,aes256-ctr,aes256-cbc,rijndael256-cbc,,aes192-ctr,aes192-cbc,rijndael192-cbc,aes128-ctr,aes128-cbc,rijndael128-cbc,3des-cbc,blowfish-cbc,cast128-cbc
           Server to Client Encryption:,,aes256-ctr,aes256-cbc,rijndael256-cbc,,aes192-ctr,aes192-cbc,rijndael192-cbc,aes128-ctr,aes128-cbc,rijndael128-cbc,3des-cbc,blowfish-cbc,cast128-cbc
           Client to Server HMAC: hmac-sha2-512,hmac-sha2-256,hmac-sha1,hmac-md5,,hmac-ripemd160
           Server to Client HMAC: hmac-sha2-512,hmac-sha2-256,hmac-sha1,hmac-md5,,hmac-ripemd160
           Client to Server Compression:,zlib,none
           Server to Client Compression:,zlib,none
[18:28:44] Key Exchange Algorithm:
[18:28:44] Server closed connection
[18:28:44] Connect failed. Error=0x80043112
[18:28:44] Waiting to retry (30s)...
Strange thing is that it does something with certificates here even though I only activated "passworc" as authentication mechanism and using keys would not work because I have none.

Contact support: menu: Help->Request support and send the server ip.

I too am receiving this error.    Yet only since an update.   previous versions were running correctly.
"An established connection was aborted by the software in your host machine
Connect Failed.   Error=0x80043112
Running Win 7 64bit.

SmartFTP  5.0.1354.0
As requested by support I have uninstalled Firewall and Anti Virus.
Error still exists.
I cannot even connect to
I also cannot do a fresh install of Win 7 as I have no other computer available.
Any help gratefully received.

The problems are unrelated. Closing this topic.