Cannot install latest version 'sfFTPLib.dll is not registered correctly' 4.1.1263.0

Licensed user here. I have downloaded the latest version 4.1.1263.0 (64bit) to my Windows 7 machine. After install, I try to run it and I get the error 'sfFTPLib.dll is not registered correctly'. This is a fresh windows 7 install

I have:
1) Rebooted the computer
2) Redownloaded the file
3) Remove the previous installation
4) Reinstalled
5) I get the same error

I also tried the 32bit version but got an install error that I had selected the wrong type.

I tried to contact support, but the KB link says I have to request within the program......which won't run.......

Maybe your software firewall or registry cleaner is causing the problem?

This is a brand-new install. This is the *first* application to be installed. I turned off Windows Firewall to double-check, still getting the same error.

I also tried reinstalling, and selecting the 'Repair' option, rebooting and trying again. This is very frustrating.

Do you have the SP1 for Windows 7 installed?

Open a command line as admin, go to the SmartFTP program files folder, then enter regsvr32 sfFTPLib.dll

Yes, I am running Windows 7 Enterprise, SP1. I typed that command, and I got the following error:
"The module 'sfFTPLib.dll' failed to load. Make sure the binary is stored at the specified path or debug it to check for problems with the binary or dependent .DLL files. Invalid access to memory location"

To confirm I had the right file, I tried the same command outside the SmartFTP directory, and got the same error message, except the bolded part above now said "The specified module could not be found". So it's finding the module, but the module is trying to access somewhere in memory it isn't allowed to.

I'm still unable to install this, has anyone else encountered this issue? I'm using CuteFTP as an alternative, but since I bought a three year license to SmartFTP I want to make the most of it - or get a refund.

Please contact support:

Sorry, the only way to request technical support is within the program - which I can't install! I mentioned this in the first line of my post.

Try to install SmartFTP on a different computer.