Nothing shows on my homepage

Please help! I'm totally new at this, but thought I followed the SmartFTP tutorials, and everything happened exactly as they said with all the icons ending up in the remote browser window. BUT when I go the web address I used, I only get the message:

"Temporary homepage for account '...'
To replace this homepage, use your ftp account to replace the file "index.html" in your root directory. Note: your ftp user name is '...', and your ftp password is the password you supplied during the creation of your account".

I replaced the actual account and user names in the message with '...' for confidentiality reasons.

I'm using a grapevine web address and trying to upload a family tree web page output by the Legacy family history software. Maybe a bit complicated for a first attempt at a web page

You need to replace the index.html/index.htm/default.htm etc with your start page.

You need to replace the index.html/index.htm/default.htm etc with your start page.

Wow! Thanks for incredibly quick response! Unfortunately I don't know what or where those are. I only got this far because of the really excellent illustrated step by step tutorials.
Is there another tutorial with pictures that explains?

You need to replace the index.html/index.htm/default.htm etc with your start page.

OK, trying to work it out. I can see things called "index html" and "index.htm" among all the stuff in the SmartFTP remote browser window, but nothing either there or in the "web" folder under "Legacy" in my C drive is called "Start page". Is that the front page I see when Legacy invites me to see my web page in my browser?

Thanks for quick initial response mb, but don't quite know what it means or what to do next. Guess you don't have time to explain? Maybe SmartFTP is too smart for me.

Try the following:
1. Delete the index.htm and index.html file on your server (in the Remote Browser)
2. Now refresh the root of your website in your browser. e.g.
3. You should see a 404 file not found error or similar (if not go back to 1).
4. Now in the folder on your computer (Local Browser / Explorer) which contains all the files of your website you want to upload there should be a file called index.html, index.htm, default.htm, default.html. If yes, then just upload everything and refresh the page in the browser. If there is no such file, rename the page you want to be displayed when visitors are going to root of your website to index.html and upload it.

OK mb, I paid Hope you're patient!
Regarding step 1, is this something I do in the SmartFTP screen, so I delete them from the remote browser there?

Yes in the Remote Browser.

Step 1 and 2 done, and yes, my web site looks a bit more promising now. At least it has a long list of all the things that are in the remote browser window in the SmartFTP window. There's no error message as such though. Do I now try step 4 and is that something I do in the SmartFTP window?

Yes just rename the html file you want to have as your start page in the Remote Browser (in SmartFTP) to index.html then refresh your page in the browser.

Sorry mb. I bet I'm both your dumbest and most determined client today! In the far left side of the SmartFTP screen, where the data corresponds to what's in my computer, there's a thing called "index", but not "index.html" or any of the other things. Will that do?

And by far left I obviously meant far right!

Try to disable the [ ] Hide extensions for known file types in Windows Explorer:
1. Start Windows Explorer (explorer.exe)
2. Go to the menu: Tools->Folder Options
3. Go to View tab
4. Uncheck Hide Extensions for known file types
5. Click OK a couple of times

Now restart SmartFTP. You should see the file extension (.html, .htm) of your files now.

It seems ridiculous, but I can't find Windows Explorer among the vast array of programs on my computer (sigh). There's some hope though. I've discovered that I can open the web pages if I double click on them in the far RIGHT screen of Smart FTP, so I do know which is the intended front page of my website. Where now?

Start button
All Programs
Windows Explorer

Done. Thanks, and jumping ahead, Yay! I have a sort of website - except the images aren't displaying and I can't get from other pages back to the home page. Still, I feel I owe you a beer or something. Can you help me further or should I examine the settings in the Legacy file?

For the images, check the following:
1. Are the image files (.png, .jpg) on the server? If yes are they in the correct folder on the server?
2. Check lower/upper case of the files. On your local computer the case is insensitive, on the webserver the case is sensitive if the server runs on any Unix.
3. Check the img references in your .html files. Are they pointing to the correct path?

Yes the images are on my computer and look fine in the browser preview that Legacy gives while building the web pages. I'll check the other things you asked and get back, but meanwhile I'm trying to reload from scratch after changing some of the settings in the website, for example it asked of I wanted htm or html as extensions, have changed it to html. How do I empty out the old one from the remote browser window? If I copy across a new version it appears to run through the transfer queue beautifully, but the data in the remote browser window remains unchanged?
OK I've discovered i can remove them about 10 at a time using control and Alt though there must be a better way as I have over 400 pages.

SmartFTP only uploads files that have been modified. Files that are "equal" are skipped.

If you want, you can delete all the files in the Remote Browser and then upload them again. But this is not really recommended.

Sorry I edited my last as you were replying. So why didn't my changes show?, such as different coloured background selected? And should I have chosen .htm or .html as the extension for all pages when legacy gave the option?

OK I did that, but i see what you mean - quite laborious. The pictures look fine now and I can get back to index page. BUT the webpage opens looking like the below. I may have copied the folders across at too high a level. How do I make it open at the home page? It is already index.html.

"Name Last modified Size Description
Parent Directory -
family history/ 04-May-2011 15:46 -
familyhistory/ 04-May-2011 15:46 -
Apache/2.2.9 (Debian) PHP/5.2.6-1+lenny8 with Suhosin-Patch mod_ssl/2.2.9 OpenSSL/0.9.8g Server at Port 80

yes you should copy/upload the files inside the familyhistory folder to the parent folder.

Thanks for your patience mb. I think I've got the hang of it sufficiently to do what I want to now. I've taken a while to get back because I wanted people to test the website for me. The "Parent directory" stuff was an issue with the webspace provider, not a problem at all. It all seems to work well. You have a satisfied customer! If I have other questions I'll try to find a relevant thread on the forum. Best wishes.