Only Upload File.Lnk not whats its linked too

How do i set it so it only uploads the file and not what its a link too?

Example ABC.lnk I need this file uploaded not the ABC.exe its tried but failing to update since file size is different.

I changed Resolve Links [-L] and Automatically Resolve Links and still get the same issue.

[10:58:09] Destination File: Size=1036288, Date Modified=2005-02-23T20:33:44
[10:58:09] RecentTime=2011-04-05T14:57:50
[10:58:09] No rule matched. Default Action="Overwrite".
[10:58:09] PASV
[10:58:09] 227 Entering Passive Mode (X ,X,X,x,92,29)
[10:58:09] Opening data connection to X.X.X.X Port: 23581
[10:58:09] STOR ABC.LNK
[10:58:09] 150 Opening BINARY mode data connection for ABC.LNK.
[10:58:09] 361 bytes transferred. (2.09 KB/s) (168 ms)
[10:58:10] 226 Transfer complete. 571 bytes (359 compressed to 62.87%) transferred. 2.80 actual KB/sec, 4.46 effective KB/sec.
[10:58:10] MFMT 20050223203400 ABC.LNK
[10:58:10] 213 Modify=20050223203400; /XXX/XXX/XXX/XX/ABC.LNK
[10:58:10] MFCT 20101115212739 NMEETING.LNK
[10:58:10] 213 Create=20101115212739; /XXX/XXX/XXX/XX/ABC.LNK
[10:58:10] MLST ABC.LNK
[10:58:10] 250-Listing /XXX/XXX/XXX/XXX/NMEETING.LNK
[10:58:10] Type=file;Size=1036288;Create=20031113153055.390;Modify=20050223203344.569;Perm=rwfad;Win32.ea=0x00000020; XXXXXX
[10:58:10] 250 End
[10:58:10] Source File Size=571, Destination File Size=1036288
[10:58:10] Possible file size discrepancy found. Please contact the server administrator for assistance.
[10:58:10] File size mismatch.
[10:58:10] Transfer failed.
[10:58:10] Operation End

Testing now but everything i try it creates the File but the size is different. Is it uploading the linked file>?

In my opinion, the server should return the size of the link and not the size of the linked file.

Ok so i see links are different from shortcuts. So my issue is with a Shortcut .lnk file

But this file works OK with my current FTP client. so there must be a option i dont have set or not available.

Looks like my other Client is only checking XCRC after Upload and not Size also

This still doesn't mean the server is returning the right information.

Also it is not uploading the Shortcut file. i just checked i dont even have it on the system. and it would be bigger than 1mb So i dont know where its getting the different size from.

OK. thanks maybe i can test another server? is there a public one i can upload a test .lnk too?


Looks like server-u 9.1 had the issue and now 10.5 looks OK for this. Again SmartFTP client is looking great and will be next purchase.

Thanks for the support!