How to reset queue if "Waiting for children to finish"

I have defined a queue to upload (Move) all content of folder. Children was generated and uploaded ok but at delete from source files was already deleted and children went into error. Could not find sourcefile to delete.....
I stopped queue and removed all Children. But now I'm stuck with parent at status "Waiting for children to finish".
I have tried to start/stop queue. No luck. I have restarted SmartFTP. No luck...

How do I reset parent to status idle ?

Please post the system information from the menu: Help->About "System Information" dialog. Thank you.

Please post the system information from the menu: Help->About "System Information" dialog. Thank you.
+- System -----------------------------
Microsoft Windows Server 2003 "R2" Standard Edition
Service Pack 2 (Build 3790)

CPU Speed : 2398 MHz
Total Memory : 2047 MB
Free Memory : 2047 MB

+- SmartFTP ---------------------------
Version : 4.0.1132.0
Time Stamp : 2010-08-01 23:01:07
Platform : x86
Id : 400114139
Maintenance : 2010-09-11
Days in use : 434

+- Language ---------------------------

+- Internet Explorer ------------------
Version : 7.0.5730.11

+- Winsock ----------------------------
Winsock : 2.2

Already updated last month inside PRO licens period and now... im outside. As far I know PRO can't install unless new licens is subscribed, and I am not likely to do that just to try out. Any solution to that ?

Sure queue will properly get working again, but that I can also achive by deleting queue and recreating hole stuff.
I checked your change logs, and I don't see anything related to an error like this. Is this a known bug that is solved ?
Update will only consume time and money to get installed in our hosted enviroment and as I see no guarantie of succes....
What to do ????

It's correct you need to renew the maintenance. The maintenance includes technical support and the upgrade protection.

Now upgraded to ....1139 and bought new PRO licens. No improvement. Transfer queue is still waiting for children to finish. Any suggestions ?

Try to manually remove the item from the transfer queue.xml file. You can find the file in the %appdata%\SmartFTP\Client 2.0 folder.

Removed hole file. But took a back-up.... Now queue is gone and I need to start all over. I tried to open transfer queue back-up file but that don't seem to work...
I think it would be usefull to have a reset button on Transfer queue that can put status on item from "Waiting for children to finish" to "idle".