high CPU loading

SmartFTP 4.0.1054.0 No language pack installed. AMD Athlon 64 x2 4600+. If there is some speed limit enabled then CPU loading by SFTP (during uploading) is over 50%. What is the problem?

Post the system information from the menu: Help->About "System Information"

What protocol are you using? Post the log from the transfer.

Thanks
Mat

For testing purpose please remove the transfer limit and then try again.

Thanks
Mat

No problem:
Image

Hm so far I'm not able to reproduce it.

Does it happen if you have a speed limit but only use 1 Worker instead of 10?

Do you have other products as net limiter etc installed?

Regards,
Mat

I think I know where the problem is coming from.

I wasn't asking about other applications in general but ones that hook into Winsock. Typically these are software firewalls, programs to control the max bandwidth (netlimiter) and antivirus products.

Regards,
Mat

I've turned off Kaspersky Internet Security and the problem has gone. But SFTP was added in "trusted applications" in KIS and the function "do not control traffic" for SFTP was on. So is it possible to use KIS and SFTP in limited mode at the same time? What should I do for it?

My recommendation is to drop Kaspersky and use the firewall that comes with Windows 7. I recommend you report the bug with the Kaspersky firewall to the vendor.

Thank you.

I will try implement a workaround that should at least help to keep the cpu usage lower.