Connection retries and unicode file names

I look at SmartFTP this morning and found out two things about the transfer queue that I put in to transfer overnight:

1. I have queued a couple of files with unicoded filenames to be transferred. It did not happen, the log says that it can't find the file/directory. The filenames are displaying correctly in the browser though.

2. Given that the files are failing to transfer, SmartFTP keeps retrying with them. Since they are at the top of the queue, the bottom ones get stuck.

So my question is,
1. Why it says that it can't find the file/directory? I then rename the UTF-8 filename to English and it transfers seamlessly.
2. Anyway I can specify the number of retries and cancel the queue item, instead of retrying it forever?


>1 utf8
Your server most does most likely not support utf8 (or not correctly) and therefore you see the transfer problems.

>2 retry
You can set the number of retries in the Favorite Properties->Connection dialog. Then set the max retry value.

>1 utf8
Server is Centos5 with vsftpd. I tried using cyberduckFTP (mac) and did the transfer with no problems.
I'm wondering if there's any settings in SmartFTP that I need to check for utf8 encoding?

>2 retry
Found the option. Thanks!

Earlier versions of vsftpd (and maybe the current version as well) have known problems with UTF8. We strongly recommend against vsftpd. A more reliable ftp server software is proftpd.
You can change the Default Code page in the favorite properties under FTP->Transfer, however it won't fix the broken server.


Thanks for the reply mb. But how do you explain that it works for CyberDuck?

If you think it is a bug with SmartFTP feel free to post a bug report in our tracker with a proof which shows that the problem is with SmartFTP.

mb, thanks.

I changed the default encoding in the favorite properties under FTP->Transfer to utf8 and now the transfer works fine. Thanks very much.

One more question I would like to ask: How do I set the default multi-part transfer?

Currently I set that by right-clicking a file in the transfer queue -> Properties -> Advanced -> Multi-part Transfer


It is currently not possible to set the files to be transferred in multi parts by default. One reason is that multi part transfers should be more the exception because the TCP window auto tuning mechanism (available in SmartFTP and on Windows Vista+) should improve the transfers drastically over high BDP networks.