Upload restarts/resumes transfer from beginning of file

I am using SmartFTP Client 3.0.1027 and for the past couple of weeks I have successfully been uploading huge files, some several gigs. I have stopped and resume has worked flawlessly.

I'm now uploading to a new site (ADrive) and so far I have uploaded 20+ files of about 500MB each. Recently, I started an upload of a 24GB file and it was proceeding fine. Then I stopped it at the end of the day when it was near 50%. To my surprise, when I resumed the next day, it started back from the BEGINNING! That was a shocker, because resume has always worked for me.

Then today, I decided to upload a smaller file, 7GB. This I know would get completed before I left work and it was proceeding fine until, all of a sudden, when I checked later, it was also restarted back at the beginning!!

Arrgghhh! I can't seem to do the upload anymore!! Is it ADrive? Is there some log I can check or look at some settings?

Please help...I really need to offload those backup files.


Hello Nusaram ..

Please install the latest version of SmartFTP:

Double click the file that is transferring in the transfer queue. The log window opens. When the transfer aborts (that is normal and happens) you will see why the file is restarted instead of resumed. You can post this information here and we can tell you how to adjust the file exist rules.


Hello Mat,

The version that's there for download is the version I already have installed.

Here's a synopsis of what I have been experiencing:
  1. I first had problems uploading folders, as I was experiencing a "550 File or directory does not exist" error;
  2. I read in a thread that a solution was to disable MLSD. I tried that, and it worked; folders were now being automatically created on the FTP server without any errors;
  3. I also read in another thread about a timeout problem and I saw a timeout entry in my log. I set the timeout to 10 minutes--that didn't change anything;
  4. I then set MLSD back to "Use Default Settings" and the upload completed without a restart;
  5. Clearly, disabling MLSD was the culprit.
So I guess my question now is:
  • Since I can manually create folders on my FTP server wthout any problems using SmartFTP, how come when MLSD is enabled, the upload process gets a 550 error when it is trying to create folders?
Perhaps there are other settings I need to make?



Post the system information from the menu: Help->About "System Information" dialog.

You know what, unfortunately I have to take back what I wrote earlier.

Rather than doing the test on the 24GB file, I had done the test on an 850MB file and it worked fine, so I thought eveyrthing was solved.

The 24GB file is back in a loop...it finishes, then restarts. I see no errors in the log.

Double click the file in the transfer queue. Then post the log here.

Also please dont forget to post the system information.


Unless I'm doing something wrong, when it restarts, I get a new log when I double-click; I'm unable to see the entries from the initial transfer request.

However, I did have the window open and I was watching it and I did catch a glimpse of an error. The problem is now resolved and the culprit is ADrive. The error I saw in the log window was from ADrive stating that 2GB is the maximum file upload. And that did ring a bell!

The other site I was using didn't have that limitation, which explains why I didn't experience any issues with my big files on that site.

Anyway, I dumped ADrive and am using a new service, which is WebDAV-based, so I hereby add my name to the list of those requesting WebDAV support.



Thank you for your feedback.