Client Closed the Connection

I'm trying to upload pictures to this website I'm helping on. I'm absolutely a dork if it is about computers, so I just don't understand this.
The log says:

[09:04:37] SmartFTP v3.0.1027.5
[09:04:38] Resolving host name ""
[09:04:38] Connecting to Port: 21
[09:04:38] An attempt was made to access a socket in a way forbidden by its access permissions.
[09:04:38] Connect failed. Waiting to retry (30s)...
[09:04:38] Client closed the connection.
[09:04:38] Active Help:

So, I tried things with the firewall, at least some people say it can be that. But it still isn't connecting. I hope you can help me ^^

Hello ..

It looks definitively like a software firewall / antivirus product problem. Please add SmartFTP to the exceptions in your software firewall and antivirus product. If this does not work temporary disable your software firewall / antivirus product.


Well, as far as I know.. I did that.
I closed my AVG Anti-Virus as far as I know and my Firewall allows SmartFTP.

But when I click the right mouse button on my AVG Interface, it says ''add SmartFTP to temporary Queue''
But when I click that, nothing happends.

I added a screenshot to show it, just in case:

You have to add SmartFTP to the exceptions inside the AVG and firewall settings.


It is.
The program is in the exceptions list of both. But it keeps giving the same error.
Should I delete the program and install it again?

It the problem is just my computer then I guess there is nothing to do about it.

Thanks for your help then anyway ^^

Temporary disable your software firewall and antivirus product and try again.

It is still not working

Temporary uninstall your software firewall and antivirus product.