Windows Vista not allowing connection


I'd like to use this software but my computer isn't cooperating. I run Windows Vista.

This is the error I keep getting:
[12:47:50] SmartFTP v3.0.1026.32
[12:47:51] Resolving host name ""
[12:47:52] Connecting to Port: 21
[12:47:52] No connection could be made because the target machine actively refused it.
[12:47:52] Client closed the connection.
[12:47:52] Active Help:
[12:47:52] Connect failed. Waiting to retry (30s)...

I've tried adding SmartFTP to the allowed programs in Windows firewall and turning it off entirely with no luck. I was thinking it was something to do with my network configurations and I'm hoping somebody can walk me through what I need to change. This isn't the only program that I've had trouble with. Programs like Command Anti-Malware cannot download their updates either. If someone knows how to get Vista to allow this transfer, that'd be great.


Hello ..

The problem is not caused by the Windows Firewall. Do you have any other software firewall / antivirus product installed? If yes try to add SmartFTP to the exceptions in these programs. You may need to uninstall the software firewall or antivirus product temporary if the setting change do not have any effect.