Downloading Problems with SmartFTP 3.0

I'm trying to download the files on the server so that I can edit them and put them back up.

I've tried different methods, all which start up a Transfer Queue. Dragging and dropping the folder I want to copy from the server into the folder in Windows Explorer, or right clicking in the Remote Browser window and Downloading, et cetera.

Anyway, the Transfer Queue starts up, and all the folders are transferred, but not all the files. It says "Retry at: blah" for most of the files I am trying to download. Some files came through, though they seem all around 1KB in size. That's the correct filesize that they are on the server. There's a few other files that have downloaded, but the biggest one is about 30KB, and there's other files on the server that I need that are larger. I don't think it has downloaded all of the small files, too.

I've tried the instructions here (changing File Exists Rules): ... opic=15421
And here (changing settings regarding Too Many Connections): ... f2602.html
And I looked at this, which seems closest to my problem, and I think the issue is quite common as discussed there, so it should be made easier for us neophytes: ... opic=15281

I've tried multiple workers, one worker; closing Remote Browser, having it open; et cetera.
I even removed SmartFTP 3.0 and downloaded version 2.5 of SmartFTP (which worked for this same server perfectly before, by the way. I have done this before in the previous version I had, of SmartFTP, and it worked fine, and I could download everything, edit it, and re-upload perfectly), but this version would only give me the "Your build is about to expire" and then wouldn't open the main program. So, I've gone back to the frustrating problem with version 3.0.

I've tried multiple times. For hours, actually. I'm on Vista, 32-bit, though when SmartFTP 2.5 worked for me, I was on an XP computer.

Alright, before you ask, double clicked on the file in the Transfer Queue for the log:


[17:27:27] Transfer failed.

[17:27:57] CWD /

[17:27:57] 250 CWD command successful.

[17:27:57] PWD

[17:27:57] 257 "/" is current directory.

[17:27:57] SIZE index.htm

[17:27:57] 550 index.htm: Access is denied. 

[17:27:57] File exist check failed. File not found or permission denied.

[17:27:57] PORT 10,1,1,2,200,98

[17:27:58] 200 PORT command successful.

[17:27:58] RETR index.htm

[17:27:58] 550 index.htm: Access is denied. 

[17:27:58] MDTM index.htm

[17:27:58] 550 index.htm: Access is denied. 

[17:27:58] STAT index.htm

[17:27:58] 213-status of index.htm:

[17:27:59] 11-16-08  01:01AM				 2586 index.htm

[17:27:59] 213 End of status.

[17:27:59] Transfer failed.

As you can see from the log you do not have sufficient permissions to download the file:
[17:27:58] RETR index.htm
[17:27:58] 550 index.htm: Access is denied.

Please contact your web hosting provider for assistance.

As you can see from the log you do not have sufficient permissions to download the file:
But I could do it before with, the last time I used SmartFTP, the older version on my other computer? So, that doesn't seem to match up.